Logic Studio apps Mainstage asks for my serial number every start up


I just upgraded my laptop to one of the new i7 macbok pro and installed logic pro 9 on it. Now Mainstage asks for my serial number 95% of the time I start up the program. Logic works fine and does not display this behavior. For one day I started logic first then used Mainstage and it didn't ask for the serial. I thought it was fixed but today it asks for my serial everytime I open up Mainstage 2.1.1 One of the times it asked for me to register with Apple and send them my info. I have already done this yet I turned on airport to send it again. This did not help.

Why does it continue to need the serial number everytime I start up.

Why the erratic behavior conserning this issue?

I only have logic pro 9 installed, Soundtoys plug-ins, and Melodyne. This laptop is to be an audio only machine for stability. That's why I want airport off. Could that be causing the problem? It sucks I'm having problems even on a stripped down, no internet, brand new top of the line Macbook pro.

Extremely frustrating after spending my life savings on one of these laptops :)

Any help would be extremely appreciated!!

Sounds like you might have a corrupted plist file (new name for a preferences file).

Try this: go into your user folder, then library, then preferences, and finally remove the com.apple.mainstage.plist file. Just put it on the desktop until we are certain that is the issue.

Try and relaunch Mainstage and see if this behavior has stopped.

If it has, great, if not, it must be something else.

Have yu tried to rebuild permissions? Open Disc Utility and repair permissions. That might also fix the issue.

George Leger III


Thank you for the extremely helpful answer. I repaired my disc permissions and it starts up fine now.

This is a brand new macbook pro and so far I've only installed Logic pro and a few plugs. I guess the preferences file must have become corrupted during installation.

Thanks again!!



It came back!!

I was about to go nuts but I realized what was different this time.

If my ilok is plugged in it does not ask for the serial number but if I do NOT have my ilok plugged in Mainstage will ask for my serial number.

Why does this happen?

The only plugs on my iLok are the Soundtoys v4, Ivory, and Melodyne.

Yet Mainstage has nothing to do with the iLok except to load plugins or not yet if it is not plugged in than it triggers Mainstage to ask for the serial number.

I will report this to Apple.



Still Not Solved

Mainstage and logic will randomly continue to ask for registration and/or my serial number even though I have already entered that information. After contacting Apple support and spending hours spanning multiple days they realized this is a bug. Here is the current reply from tech support:

Hello Todd, I'm afraid you will not be notified
directly if/when the serialization issue is resolved.

Regarding troubleshooting your system, you could
keep the Activity Monitor up and running when you
are using MainStage, set to show All Processes,
and see if you notice any spike in CPU usage of
one of the process that corresponds with when a
spike occurs in MainStage.


David Paulson
Apple Inc.

So according to apple they MAY fix this bug. "IF" it gets fixed. I spent top dollar for the latest macbook pro i7, and I purchased my own copy of Logic pro. I find this heartless reply to me, the customer very saddening. Randomly Mainstage and Logic will continually ask for me to enter my serial number and maybe one day there will be a fix or it could be an indefinite issue? ....and that's it case closed?

I am one very very unhappy apple customer. If you are planning on purchasing a top of the line macbook pro to use Mainstage problem free in a live concert setting then you could be in for extreme frustration with a large dose of buyer's remorse:(
Reading your last email, I wonder if the issue isn't Mainstage or Logic, rather an AU plug-in that is using the ilok...

That makes sense here as I think of it. I have seen and used logic on about 40 different systems over the years, and a number of my tech clients have i7 based systems, I really don't think that is the issue, and I also think Apple tech, while handy, can only go so far. I think they are suggesting it's a bug because they have no idea one way or the other.

Start Rant:
Just in case you think I'm some apple fanboy, protecting the party line... I have had the worst tech and hardware experiences with Apple over the years (27 to be exact) they are just another corp who wants your money... their stuff is not bad, but hey...
A good example if the iphone... after 3 years, and lots of crap to AT&T, seems the antenna has been an issue with the iphone dropped calls and bad reception since day 1. While AT&T are bad, Apple is not really any better.
End Rant.

I have a pretty good intuition about this stuff, and after your last post, I suggest the ilok is the issue here, not mainstage.

George Leger III



Thank you for your reply and bringing some perspective to the table. I do have an ilok with Soundtoys plugs and also Ivory. How would I go about troubleshooting an iLok? Is there anyway to reset it?

Although I did do a fresh install of OSX and Logic and the problem persisted.... but maybe I didn't realize it came back after installing the programs that use the ilok. I'm going to install Logic on my regular macbook, since it does not have the ilok installed, and see if I do not have problems.



I'm with George's hunch on this. It is highly likely it is one of your third party AUs that is asking for the registration info when the iLok is unplugged.

You say you have reinstalled everything, but what is Logic's behavior set to do at start up? Is it launching a template that has these plug ins somewhere in them? That is my suspicion.

Try this: Open your Logic prefs and set the start up behavior to do nothing when Logic is launched. Then observe the behavior when you launch Logic after that and see if you are prompted for registration info without the iLok. This will rule out once and for all if it is a third party AU that is the source of the problem. If, as I suspect, you don't experience the problem, move on and create a new default startup template from scratch without any plug ins, set that to launch at start up, and see if the behavior changes. I suspect it should all work fine at that point.

Having said all this, I have FTR observed strange behavior on different client's systems where Logic asks for registration info on already registered systems. The behavior seems to be tied to people who have upgraded from Logic 8 and occasionally need to switch back and forth between Logic 8 and Logic 9 It's seems to be more a nuisance than anything serious though.


Thank you for taking the time to help Eli. I changed my Logic start behavior to do nothing and do not have the ilok plugged in. After the 5th startup it asked again for me to input my serial number:( I'm going to keep trying today and I'll update the thread if I find anything interesting.
Try this:

Open Logic Pro, then under the Logic menu, open AU manager. Un check any 3d party plug-ins.

Now try.

If you have an ilok plug-in that has been installed in the past, and remove the ilok, it could be the cause of the issue.

DO you actually get a dialog asking for the Logic Pro serial number when this happens? Could you please take a screen shot using your Grab app (in the utilities folder) next time this happens and show us?



I have unchecked all 3rd plugs in the AU manager and it started up 5 times fine then the next time I opened the program I was again prompted for my serial number. I have attached the screen shot.

Thank you for helping me out,



  • Screen-shot-2010-07-11.jpg
    37.7 KB · Views: 162



I had further problems with my Macbook pro i7 17" so Apple decided that all I have gone through is unacceptable and replaced my computer. I now I have a brand new macbook pro with new serial number. I received the computer, installed logic 9, did Apple's software update.

Still the same behavior!!!! I have nothing else installed on this machine. Apple hardware/software. Mainstage will continue to ask for my serial number upon starting up. It does not even make sense why Mainstage needs a serial number because it is part of the Logic Studio application and uses the same serial number that I have entered while installing Logic.

After calling tech support my last ditch effort was to erase the hard drive, reinstall snow leopard, install the Aperture 3 trial, then install logic and apple's software update. Mainstage still continues to ask for my serial number multiple times.

This is proof that with these specific computers this is an issue.
Would you please go to the apple menu, select "about this mac", then press on "more info" and send me/us the specific model identifier of your mac?


The model identifier is MacBookPro6,1

It is the 17" Macbook pro Intel Core i7 2.66 ghz with 4 gigs of ram.

I have now video documented the process of me erasing the hard drive, installing snow leopard from scratch, then apple update, install logic 9, apple update, then showing mainstage's behavior where it will repeatedly ask for the serial number. I did this to show that there is no user error.


New Member
Same issue on 15"MB Pro

Hi -

I've been grappling with this for a while. It's not specific to 17", but maybe the new processors? (hardly likely I'd have thought). Bought brand new MB Pro with new install of L9. No problems with installation but then starting getting continuous prompts for serial - total pain.

First theory was AU conflict. Proved to be not the case. Went through all the business with Apple. First suggestion was that if I'd opened Mainsatge or Compressor first that would have caused the issue. Nope - humbug. Next try the free Aperture download - nope. Then trash the proApp library files - aha - worked for a couple of times, but then it came back. Finally the guy from Apple matter-of-factly (and a bit sheepishly) informs me that "there is an issue and our engineers are aware of it - it will be addressed in an update".

So up until now I have been carrying around my old XS key - old skool - and always booting up with that in.

I'm about to do the 9.2 upgrade - there's no word in the release about this issue being fixed (or even acknowledged). I'll be interested to see if anything has changed for the better.


New Member

I meant 9.1.2

Guess what - it hasn't been fixed. Yay Apple. Good job on being Apple. God I miss emagic.


You can't authorize the applications finally, only the _installer_ can do that. So, please reinstall from the original DVD.


No it's still not fixed. It definitely has to do with the newer processors. At least they admit to it now. It took me awhile to get them to that point. I even made a documentary of me showing the repeatable behavior starting from a fresh install of OSX.

I have been pretty disappointed in the horsepower with this machine as well.(MBP i7 17")


If it's any consolation, i have the same &%#$ issue. I use Mainstage professionally and it's mildly annoying to have to go through that dialog box each time I load it up at a gig. I've resolved it by having my serial key in a text file on my desktop so I can copy and paste it when I load.

I'll keep watching here to see if a solution emerges.

Oh, by the way, I have a 2010 15" MBP w/ the 2.66 i7. I suppose that could be the issue, but I don't know why it would be.


The 2010 i5/i7's were exactly the ones with this prblem but mine has since gone away with OS updates. Are you using at least 10.6.5?