Logic Pro X Maxing out CPU with summing template

Rocwatson

New Member
I am on logic 10.5.1 and Mac OS 11.6. I am running a 2020 10 core iMac with 80GB memory. 2Tb SSD drive

I have my template set up for a 16X2 summing mixer. So I send out 8 stereo auxiliaries and bring them back in logic through a stereo audio channel.

(which is how I monitor the mix while I record individual channels). I am getting max CPU spikes and digital distortion. I adjusted buffer to 512 and it helps

a little bit. When I mute the input audio channel my CPU usage goes way down. I believe my issue has to do with monitoring/recording the mix through the armed

audio channel? What do you think? Can you think of a workaround?

Wats434
 

fuzzfilth

Logician
While I can't offer a workaround, you should be able to do this without problems. Merely routing audio to ins and outs takes pretty much no CPU whatsoever, even less so on a new machine, and you should be able to do it at 64 or even less buffer size.

Here is the Performance Meter of Logic Pro X 5.1 on a 2010 Mac Pro while I am re-recording a mix or 20 tracks into Logic at 32 buffer size, so your machine should do substantially better.

Bildschirmfoto 2021-09-28 um 13.07.30.png


Can you show a screenshot of Preferences>Audio>Devices ?
 
Upvote 0

Rocwatson

New Member
While I can't offer a workaround, you should be able to do this without problems. Merely routing audio to ins and outs takes pretty much no CPU whatsoever, even less so on a new machine, and you should be able to do it at 64 or even less buffer size.

Here is the Performance Meter of Logic Pro X 5.1 on a 2010 Mac Pro while I am re-recording a mix or 20 tracks into Logic at 32 buffer size, so your machine should do substantially better.

View attachment 2339

Can you show a screenshot of Preferences>Audio>Devices ?
Thanks Christian for your feedback. If the issue persists I will reach back.
 
Upvote 0
Top