Logic Pro 9 merge midi with selected region bug?

I haven't been able to merge midi with selected region since upgrading to L9. It always creates a new region on top of the old unless I choose "merge while in cycle mode". I also tried this on my laptop just now with the same buggy result. I then opened up L8 (on my laptop), checked off merge midi with selected region in the preferecnces and tried it. It worked fine. I then went back to L9 on a whim and found that it is now working! I'll try it in my studio later to see if this fixes it somehow. I imagine since I fixed it haphazardly by going back to L8 that it's a bug that not everyone is experiencing, even though its been happening with me on 2 different computers. Nice to know there's a workaround.
Nothing like answering my own post. I found out that in Logic 9, if you have a midi region selected prior to recording it becomes deselected unless you press record at the very beginning. If you punch in and then start playing it becomes deselected and thus the new data is layered on top. But, if you punch in, reselect it and then start playing it gets merged onto the older data. Now, one (other) weird thing is that sometimes when I want to undo what I just did if it's merged in it undos the whole recording for that region so the region disappears. Still trying to figure that on out. In Logic 8 the region stays selected after you press play and punch in. Too bad they don't make this a preference as some might like to always merge and not have to reselect the region.
I have just upgraded to logic 9 because I finished another job and thought it would be a good plan.. this midi merge thing is really annoying - anyone got any suggestions other than deal with it?!
Sometimes it works spot-on with Merge with selected regions or Merge only in Cycle record. Notes from all passes and MIDI CC data ends up in one region as desired.

But many times I end up with two or three regions layered on top of each other. My solution has been to rubber-band select them, then Merge them: Region>Merge>Regions.

My experience has been variable.

Is there a final update on this issue or a workaround? I'm running into all of these issues now. I'm running LE 9 and am a newbie...