Logic Pro 9 midi keyboard assignment


New Member
Hi all,

I have 2 M-Audio keyboards: Oxygen 61 (midi ch 5) and Keystation 88 (midi ch 1). My M-Tron mellotron emulator is set to midi ch 5 and responds only to my Oxygen 61. I want Logic Pro 9 to only respond to my Keystation 88 (midi ch 1) but whatever settings I use, both keyboards trigger Logic. How can I solve this?
I have already consulted the forum, tried a gazillion possible solutions but to no avail. Can anyone help this newbie? 70's prog rock awaits!
There is a way, but you have to get to the environment to do this and it's a bit more of an advanced user thing.

You will need to go into the clicks and ports page in the environment, and re-cable your midi controllers to only go to the devices you want: the oxygen would have to be directly cabled to the port the Mellotron is on, and the Keystation would need to be cabled directly to a set of inputs rather than the "sum" it is currently set to.

So, I would suggest you take a look at the clicks and ports page, and then consult the reference manual to get a better understanding of how the midi controllers get assigned to inputs within the environment layer.

Wish I could offer you more, but like I said, it's a pretty specific and advanced thing you want.


You will need to go into the clicks and ports page in the environment, and re-cable your midi controllers to only go to the devices you want:
I'm sorry to say but this is an absolute incorrect advice George, which result will be no midi recording possibilities cause you cut the midi paths to the Sequencer Input!
In other words it will behave as performance setup only.

Just go to the Logic Project Settings ->Recording and enable "Autodemix by midi channel ..." box which will switch Logic into Multiplayer mode so it can channelize the incoming midi.
Set the midi tracks in the arrange (inc Software Instruments, External Instruments etc) to match the external gear midi channels you want and operate.
Actually the method I suggested would be fine. You are assuming that I would have made the main keyboard not go the the Sum.

Here is EXACTLY how I would do it:

In the clicks and ports: Take the physical input for the Oxygen 61 and directly cable it to the channel strip that contains the M-Tron mellotron emulator. Fist connection done, now the Oxygen ONLY triggers the M-Tron.

As for the Keystation, just leave it the way it is, and it will control all other devices as expected.


Here is a picture I took of the exact this I'm suggesting:

The QX49 (keyboard) controls and sends data to the sequencer input, and the LPD8 only sends data to the ES2 channel.

I'd like a bit more details from your suggested method, since I would imagine for it to work as you suggested, you would have to set up some kind of a layered instrument, wouldn't you? If not, please show me some kind of a screen shot going over how to do it, if you can...
Hi Tangra,

So I just spent a few minutes doing what you suggested. It will work. but only if the 2 tracks being used for the example we are working with are both set into record mode.

So we have 2 methods. Yours is easy to do and will work great is you are trying to record both tracks at the same time.

Mine would be more of a live setup, where you needed to change tracks and sounds and only wanted to use the Oxygen and mellotron as a live playback only device, since there is no way to record it since (as you suggested) there is no sequencer input for the direct cabled device.

So then, gdeslong, to under in a very easy to understand way do this:

Create 2 tracks in a new Logic session. Make 1 the M-Tron, and in the track inspector set the midi channel to 5. Make sure the Oxygen is transmitting on channel 5 as well. press on the record enable button on the track (the "R" that will turn red when enabled)

Make the other instrument track, instantiate an exs instrument, and select a piano sound. On this track make sure the midi channel in the track inspector is set to "1" (not "all", the default). Make sure your Keystation is set to transmit on channel 1.

Next, go into the "File" menu, and open the "Project Settings", then "Record" and in the midi section, check the "Auto demix by channel if multitrack recording" box.

Close this box and go back to your arrange page, then make sure both tracks are record enabled.

Now when you play your oxygen the M-Tron is playing, and when the play the Keystation the piano sound is playing.

Here's a strange looking this you should be aware of: when recording, only the top track appears to be recording properly. When you hit stop, or disable the record button, the midi data will split to both tracks.

gdeslong, I hope after all the confusion I made before is now clarified with Tangra's help...