Logic Pro X Miroslav Philharmonic Problem

#1
Hi. Hope this is easy! I’m a fairly new Logic user.

I’ve installed Miroslav Philharmonic, and I’ve been unable to get any sound output on playback.

If I use the MP virtual keyboard, or my MIDI keyboard, I get output. But when I play the project, I’m hearing nothing from the track I’m using MP on.

If I change from MP to a different software instrument on the same track, it works fine.

Any help is appreciated!

Gary
 
#3
Hi. OK thanks.

OS X El Capitan 10.11.6
Logic Pro X 10.3.2
Miroslav Philharmonik CE 2.0.5

MIDI channel assigned to the MIDI region in Logic? This is an area I'm not proficient in, in Logic. The output of the channel is to the Stereo Output, which is routed to UA Apollo Twin. The other softsynths I've tried on the same track are routed the same and they work fine. Of course, MP is a non-Logic instrument so maybe it's different in that regard. AU instrument?

Since MP is a multi-output instrument, each instrument I load in the control panel is assigned to a different channel, 1-16. It doesn't matter which one I choose, same result - Sound with the virtual or midi keyboard but no sound on playback.

Thanks a lot!!

Gary
 
#4
Logic 10.4.1
macOS 10.12.6
MP 2

Create empty project, add MIDI track (software instrument, choose MP 2)
Keyboard plays notes (when in proper range)
MP 2 plugin plays notes

create empty MIDI region. Add notes in proper range for MP2 instrument. Press play - notes play

Beats me. Works fine here.
 
#5
Hey! Worked for me too!

OK, now I'm more baffled!

Do you have any idea why MP wouldn't playback on an existing midi track? As I mentioned before, the other instruments I tried worked fine.

Also interesting, in the new project I created at your suggestion, I recorded another track using a different instrument, then switched to MP and it played fine!

Appreciate the help.
 
#6
Check the "broken" track and make sure the MIDI messages are being sent to the proper channel for MP 2.
Make sure MP2 has the instrument(s) that you want loaded
 
#8
Guess I don't know enough about the softsynths and midi to know how to do this. The MP panel shows the sounds being routed to tracks 1, 2, 3. The output of the track goes to sterio R/L. Same as when I tried recording with MP queued up. The track I recorded works, the pre-existing track doesn't.

??

Thanks a lot.
 
Top