Logic Pro (X) Missing EXS24 samples on LPX/Mavericks


Hi there,
I hope someone can help me as I'm really at my wits end having spent several full days trying to resolve this! :angryfire:
And I'm no novice as I've been using Logic on a daily basis since 1999.
The problem is that I have lots of samples for my EXS - some were Akai conversions, some from WAVs, some made myself and no matter where I place them (I'm loathe to put them all on my main HD as I've recently upgraded to an SSD and can't afford one big enough for my sample library) the EXS24 seems incapable of finding the audio files.
I managed to get this loading all of my sampler instruments perfectly well on my other drive where I can still load up LP9 on Snow Leopard - so it is purely Mavericks/LPX that are causing me problems.
I've tried making aliases - it didn't like that and just created additional empty folders with the same name (Sampler Instruments & EXS Factory Samples).
I've tried using the Symlink app and aiming it at each of the many Logic folders (Library/Application Support/Logic, in the User/Library/Application Support/Logic - eventually tracked down through the Go menu, AND User/Music/Audio Music Apps)
I've tried refreshing the sampler browser.
I've tried changing the EXS24 prefs to search the various disk options - still no joy.
It keeps giving me a 'Audio File blah blah not found'
Opening up the editor and double clicking the 'Bad File Name or Volume Name (perhaps zero length) - result code = -37)
I usually manage to sort these kinds of issues out but the new OS (Mavericks) and trying to upgrade to LPX from LP9 have got me in a total lather!!

Should I be indexing with Spotlight prior to booting up Logic each time anything is moved?
Is there a file

Please please PLEASE, somebody help me!
I have three folders that need placing in a way that Logic can see them and the EXS finds the audio
The folders that currently reside in their original form on my external sample drive are named
EXS Factory Samples
Sampler Instruments
Akai Samples

Can someone please lead me with this before I throw my self into the Thames...? :brkwl:

Thanks for listening - I'm off out to get plastered... :D

Same strange issue here.
EXS won't find the samples of my 3rd party library. I´m open an instrument: missing sample! After quiting logic and restarting it the particular instrument opens up with samples loaded. No prob to open it up then... I have my EXS library on a 2nd internal SSD, symbolic linked to the right folder. Checked Spotlight, reindexed all drives, switched the search in the EXS prefs to all volumes... Nothing! Should I really open up tons of instruments and quit Logic each time afterwards?!? Logic X under 10.9.5 on a 2.6 i7 quad mini

Have a good one

Upvote 0