Logic Pro X Multitrack Midi Recording won't work.

samwhorocks

New Member
Please help. I can't record parts from separate controllers. I know about auto remix, selecting multiple tracks and nothing works. All of my instrument channels receive all midi channels no matter what I do. I've even spoke to a tech at apple about this and after hours on the phone nothing worked.
 

Peter Ostry

Administrator
Staff member
Not sure what you mean. You say "from separate controllers" and "receive all MIDI channels". A controller device can have multiple MIDI ports and each port can send on 1-16 MIDI channels. Logic sees all connected devices, but it records all incoming MIDI to one track, which is a big disadvantage. There is no device selection and the only way to organize MIDI multitracking is the MIDI channel number. Therefore, 16 channels per take are the maximum. If multiple devices send on the same channel, their data get merged.
  • You can set different channels on all your controllers.
  • With DIN connections you can use MIDI hardware or software to renumber the channels based on device.
  • For USB connections you can use software to renumber the channels if necessary.
  • You can use the Logic MIDI Environment to remap channel numbers based on device. If your MIDI setup changes, there are potential problems with this method.
  • If you need to trigger software instruments with identical channel numbers, try to set the instruments themselves to different channels and set the controllers accordingly. Otherwise the instruments will get identical data.
  • In one take you can record only one full range MPE controller. You may reduce the range but this also reduces MPE capability.
If you need to record more than 16 channels at once and cannot remap them for whatever reason, Logic is not the right software for this task.

Can you solve your problem with the explanations above?
If not, please tell us the details:
Which controller devices do you use?
Which data do your controllers send?
On which channels?
Which software instruments do you want to play simultaneously?

In case you don't know exactly what your controllers do, install the freeware Midi Monitor. It can show all data of all MIDI ports in realtime.
 
Upvote 0

samwhorocks

New Member
Hi and thanks for the reply. I have three keyboard controllers, each are set to a different midi Chanel(1, 2 and 3). I want each controller to play a different instrument. Nothing much more than notes, velocity and sustain.

I've got logic on multitrack recording mode(auto demix), each track is set to the corresponding midi channel of it's specific keyboard, all three tacks are rercord enabled. I've got bass, piano and drums. I'm ready to rock n roll right?

Wrong! When I play a note on any keyboard its received on all the channels giving me an incoherent hit of cymbals, bass and piano. What the...?

Any ideas?
 
Upvote 0

fuzzfilth

Logician
You should be ready to rock n roll, because the three steps you described is really all it takes. So to get this going:

three keyboard controllers, each are set to a different midi Chanel
Do these different MIDI channels in fact arrive at Logic ? Open the Environment window, select the Click&Ports Layer top left and look at the data coming into Input View.

Bildschirmfoto 2021-04-09 um 20.09.36.png


The leftmost number is the MIDI channel which should be different from each source. Confirm this.


I've got logic on multitrack recording mode(auto demix),

Bildschirmfoto 2021-04-09 um 20.04.47.png


The option at the bottom must be checked. Confirm this.


each track is set to the corresponding midi channel of it's specific keyboard

Bildschirmfoto 2021-04-09 um 20.06.24.png


This is set in the Track Inspector on the left and be reflected in the Track Header. All three Tracks must be rec-enabled. Confirm this.
 
Upvote 0

bayswater

Logician
I came across this when trying to send MIDI from another DAW into Logic to play multiple parts on multiple instances of EXS24. The MIDI channel drop down in the Track menu in the Inspector had no effect on which channels were used. I would have though this is a filter to choose MIDI channels to be processed or recorded, but all VI instances were receiving all the MIDI data appearing at the input to Logic. The solution I got from this forum is to set up channel splitters in the Environment page. They receive data from the input devices, and send MIDI from to the specific channel strips used to record.
It's PITA to set up but once you do, you can save it in a template.
 
Upvote 0

fuzzfilth

Logician
Patching data through Channel Splitters directly into Channel Strips is one way to get multi-channel playback, but you cannot record any of this, which is a requirement in the original post.

As I said, Sam is using the right approach, we're currently verifying that all settings are correct.
 
Upvote 0

Bart Robbens

New Member
Patching data through Channel Splitters directly into Channel Strips is one way to get multi-channel playback, but you cannot record any of this, which is a requirement in the original post.

As I said, Sam is using the right approach, we're currently verifying that all settings are correct.
Thanx for your input. I'm struggling, I guess, with the same problem....
I´ve got an Arturia Beatstep pro and often record some drum patterns with this device. Unfortunatelly, every pad (sample) indeed end up in the same midi-region. Therefor I routed my pads in Midi Environement (by the use of different transformers), so every individual pad has his own track. But as you wrote: I can play them, but not record... Is there no other solution? Because otherwise the possibillity of midi routing doesn´t make any sense :)
 
Upvote 0

Bart Robbens

New Member
As you can see, every pad (in fact: every note) coming from the Arturia has its own destination - all to channel 9 but only with the exclusive note coming through. The source where my Arturia comes in is "Drum All". From there every note goes to an indiviudal track with that specific note (as you can see in my Midi Environment window). I don't understand what I'm doing wrong... As I wrote you can see them separatly when playing, but the recording doesn't do a thing, except registrate a 'midi all' region in my 'source track' "Drum All".
I think everything is set well of my recording options...
 

Attachments

  • Schermafbeelding 2021-11-29 om 11.53.41.png
    Schermafbeelding 2021-11-29 om 11.53.41.png
    3.3 MB · Views: 17
  • Schermafbeelding 2021-11-29 om 11.54.23 (2).png
    Schermafbeelding 2021-11-29 om 11.54.23 (2).png
    2.1 MB · Views: 16
  • Schermafbeelding 2021-11-29 om 11.54.23.png
    Schermafbeelding 2021-11-29 om 11.54.23.png
    3.1 MB · Views: 15
Upvote 0

fuzzfilth

Logician
You're not patching notes to Tracks. You're patching them to Channels. Channels don't record anything, they just give sound to what a Track (and your Environment Cables) feeds them. This is why you can't record what you patched here.

So you have multiple notes that are all the same MIDI channel and want them to drive a drum kit and a separate Ultrabeat, right ? Here's what I would do, in a new, empty Project:

- set up two Instrument Tracks, one with a Drum Kit Designer w/Multi-Output, the other one with Ultrabeat
- on the DKD channel, click on Settings and select Drum Kit > Producer Kit > SoCal+. This changes the single-output Channel into a Track Stack containing all the single outputs of the drum kit.
- on the DKD Track Stack Channel, change MIDI Channel from All to 1
- on the UB Channel, change MIDI Channel from All to 2
- In Project Settings>Recording enable Auto Demix By Channel If Multitrack Recording
- Open the Environment and go to the Click&Ports Layer
- Patch a Transformer between PhysicalIn and onscreen Keyboard and set it like this:

Bildschirmfoto 2021-11-29 um 13.45.18.png


- Now go back to the Main Window, click both Track's Rec buttons and record
- Upon hitting stop, both Tracks will be filled with their notes, all DKD notes will sound on their single outputs
 
Last edited:
Upvote 0
Top