Logic Pro 9 My plugins have disappeared

I need help I am running Logic 9 and I have Waves plugins, Native Instruments Komplete 8 and a Virus Snow. When I open Logic now all my Waves plugins and Native Instruments soft synths have disappeared.

When I plug my virus into my Macbook it doesn't get recognised as a soft synth. I can still run audio through it and use it as my audio interface I just can't open the virus as an insert because its not there.

I have tried factory resetting and upgrading the firmware on the Virus. I haven't tried reinstalling the NI because it is massive 260GB or something. I haven't tried reinstalling Waves but the other stuff is more important. I have tried reinstalling Logic but no fix. All the software is up to date too, I have checked that.

This problem happened after upgrading to 10.8. I have another drive that I can boot off running 10.7 and it works okay. I don't want to keep using that drive because its an external HD and slow.

I have read other forums and tried starting Logic in 32bit mode and then 64bit again. I have also tried going to my Cache folder and deleting the component file. None of these have worked. When I go to Logic > Preferences > Audio Units Manager no windows opens. Just nothing happens.

What do I do? Please help!



I've never used a Virus Snow, so I can't address anything specific to that.

Have you looked into your Mac hard drive (start up drive)>Library>Audio>Plug-ins>Component folder? Are your Waves and NI plug-ins in there?

What happens if you open an Empty project template without the Virus Snow or any other devices hooked up? Are you able to see you plug-ins in the I/O or insert slots?

In the MIDI window of the Audio MIDI Setup Utility (Applications folder>Utilities>AM Setup app), does your Virus Snow show up?

What version of Logic are you using? 9.1.8 is the latest version.
Upvote 0
Hi CSeye

When I go into Library>Audio>Plug-ins>Component folder all my plugins are there. The plugins for NI, Waves and even the Virus.

When opening a blank session I only have the standard Logic inserts. There are no other ones and it makes no difference if I have the Virus plugged in or not.

When I go into Audio/Midi setup my virus is listed there as a device but it doesnt show cables plugged in to anything. Do I need to setup the devices there?

My version of Logic is 9.1.8

Thank you for your help
Upvote 0


You mention that your Audio Unit Manager window does'nt open!
That is a problem...
Have you considered resetting your preference file?
It looks like that pref file got somehow possibly corrupted...
Alternately, you could create a different user account on your computer and start Logic from there, this would normally make Logic create a different preference file (for the new user), hopefully not corrupted...
Do that while running Logic in 32bit mode and let Logic scan your NI plugins in that mode then again in 64bit mode before plugging your Virus.
Make sure that you have the latest Virus drivers installed.
Normally cables connection in the AudioMIDI Setup window are not mandatory to have Logic detecting the gear and work with it but it helps to identify them in the interfaces (ie Environment) especially when you have many ones connected...
By the way how did you proceed with the new Logic installation?
What else do you connected to your computer?
Upvote 0


The easiest way to reset your preference file as Atlas recommended is to go to the Logic Pro menu (top left of your screen)>Preferences>Initialize All Except Key Commands. Not sure if it matters but open Logic in 32 bit mode before you do this.

Try that first before setting up another account.
Upvote 0
I created a different user account on my computer. I opened my session and everything was working! It took a while to go through each plugin at startup but it worked. So that did fix it but it would be better if I can get it going on my current account. When I checked the Audio Units Manager all my plugins were there and validated.

How do I transfer the preference file from the new user account to my original user account?

All I have connected to my computer is the virus and a MIDI keyboard. Sometimes I have a hub with Maschine and Kore connnected by atm its only the virus and keyboard.

I did try going to Preferences > Initialize All Except Key Commands....but this didn't do anything
Upvote 0


Turn off your computer. Restart it on your original user account.
Do not open Logic.
Move your preference files from
to your destop.
Make sure that your Virus is still not connected.
Make sure you are setting Logic to boot in 32bit mode.
Start Logic.
This would force Logic to scan your AUs and create new pref files.
This could take a while, let it finish the AU scan.
You should have the plugins there.
Quit Logic.
Set Logic to boot in 64bit mode and restart Logic and let it go through the AU scan process. Again with nothing connected to your computer... Once that process done you should have your AU plugins available also in 64bit (providing that they are 64bit compatible).
Quit Logic. Turn off your computer. Make sure that you have the latest Virus drivers installed. If not, proceed as directed by the Access installer. Plug your Virus and restart your computer and Logic in 32bit mode, then again in 64bit mode.
If everything goes well, deleted the pref files you have previously saved to your desktop and empty the trashcan.
Upvote 0
When I go to ~/Library/Preferences/ I don't see any files called

I tried doing a search in Spotlight and couldn't find the files on my computer.
Upvote 0


Try your [user] Library. (Where user is your account name)
The user library is hidden by default if you are on Lion/Mountain Lion.
Via the Finder / Go menu wile holding down Option.
Upvote 0