Logic Pro X New to this and getting pops

willie45

Logician
Hi folks,

I read a few threads on similar issues but I'm not sure if mine is the same. TBH I'm pretty new and I didn't really understand some of the terms people were using so can you bear with me while I explain my problem?

I have just started out and I'm using a 2012 Mc Mini with Logic and Scarlett 2i2 interface ( old USB one ) I have 16Gb RAM a nd a 2.5GHz dual core processor. My keyboards is an Oxygen 25 mkIV .

My problem is that when I use the keyboard I get clicking and popping sounds on the track.They sound like a damaged record in the old days.

I changed the connection cables with no result. I tried another keyboard and it was the same. I changed the buffer size on the interface trying from 32, 64, and 168. It seems to improve a fair bit at 128 ( could this be a clue? ) but it showed latency had rocketed. If this is the answer it seems I'm likely to have a major issue with latency and I don't know how to deal with that.

I'm not sure if the computer is too feeble but surely not with only one track being used. I have this problem when I have no other recording or anything else in the project.

I tried Garageband briefly ( I will try again more fully later) and it seems fine

Anyway, I'm stuck. I read the posts most relevant but they seem to relate to larger projects than this simple recording.

Please help if you can.

PS the problem doesn't seem to appear when using loops, just the software instrument tracks with the midi keyboard

Thanks
 

CSeye

Logician
Hello,


Are you hearing latency at a I/O buffer size of 128, or is it that you see the Resulting Latency (Roundtrip) numbers increase at 128 compared to 64 or 32? Using a lower I/O buffer size (64 or 32) makes your computer processor work harder and can produce popping and clicking sounds.

If you're not hearing latency, then leave the I/O buffer at 128 for now.

A buffer of 128 is a good starting for tracking or recording.
Increase it to 512 or 1024 when mixing a project when many tracks.
 

willie45

Logician
Hi CSeye and thank you for your reply. I can't sense a slight delay from hitting the keyboard and the note sounding. It's not much but I imagine if it goes on when I have a number of tracks I need to keep time with it might get difficult. I am just starting to learn logic and so far have mainly experimented with Apple loops so this is my first go at actually playing notes on a midi keyboard. As I said the problem isn't noticeable on the loops and strangely isn't noticeable on Garageband either. Maybe it adjusts automatically.

I installed Logic on my MacBook Pro and it seems better on that. I don't hear latency at 128 on that one. It's a faster machine with an SSD I guess?

If I get latency troubles, is the Direct mode thing on my Scarlett foolproof or is there a catch?
 

CSeye

Logician
A faster processor and an SSD will give better performance.

Direct mode is for audio inputs such as a mic, line source such as a keyboard with internal sounds, and guitar or bass.

Since Garaband sounds ok, maybe have a look at your audio preferences in Logic In the Logic menu>Preferances>Audio, check the following settings:
- Device tab: Processing threads - Automatic, Process Buffer Range - Medium, Multithreading - Playback & Live Tracks
- General tab: Plug-in Latency Compensation - All, Low Latency Mode - unchecked
 

willie45

Logician
Sorry I thought I had replied to this. Apologies. Thank you for your clarification CSeye.

Also I bought a new mini and the clicking has gone. I don't know why but assume its the better processor. I also checked the settings gas were as you suggest and I'm not sure what they were before so maybe that's helped.

But I'm not are about the "all low latency mode" or "plug in latency comp". I can't see these?
 
Last edited:

CSeye

Logician
Congrats on the new Mini. More powerful processor, better performance.

I wouldn't worry about the preferences. The default settings, whatever they are, are probably just fine.
To locate them, open the main Logic menu (to the right of the Apple menu) in the upper left, select Preferences>Audio.
 

Attachments

Top