Logic Pro X not hearing clips while editing Audio Regions in Logic X

peterspiano

Logician
Dear Logic Experts!

I've just found a bug i believe in Logic X. I was editing a CD with Logic Pro 8 (v.8.0.2) until last night when i updated to Mavericks and now there are weird black columns on the arrange page appearing.

So i'm now continuing to edit with Logic X (i never got around to buying logic 9).

My problem:

When i cut a audio region i'm not hearing the cut's even when i'm supposed to. I'm not sure how other people do this but when i cut takes from a recording session i look for where the wave forms go to 0 then i cut there. If it's a clean cut then it makes no sound and if it's "˜dirty' then i hear a "˜clip. Right now i'm not hearing ANY clips even at places where i SHOULD hear a clip.

WHY is this that i am not hearing these clips at all? It makes editing a cd suddenly very very difficult :(

many thanks for your time and for any tips you might be able to give me!! :)

Peter

Logic X 10.0.4
Mac OS X 10.9
 
Vocals

:confused: I know this is off topic, but Help if you can please. I'm unable to hear my vocals while I'm recording them, what might I be doing wrong? I'm running Logic 8 through a Motu interface and Mac.
sincerely lost.
 

peterspiano

Logician
Just a bit of an update on my problem:

I was expecting to hear a click by virtue of the fact that whenever i've editied audio regions in the past (Logic 8, 7, 6..as i mentioned i never bought logic 9) i've always heard a clip when i cut an audio region at a 'non-0-value'. I'm not sure if that's the proper term for when the wave form is not at a 0 value. But maybe you get what i mean? And this was how i always assured clean cuts when i'm working with audio regions from recording sessions. Perhaps Logic X has some kind of automatic 'take-out-all-unclean-cuts' fliter or something to this effect?

Also...i've taken the same project file and tried to do the same cut in Logic 8...and i DO hear cut's when i take the scizzors and cut at a non-0-value. This is the way i've always cut audio regions...does anyone else do this in another way?

i would continue to edit in Logic 8 but i've got this other problem with strange black colums appearing. (shows me for updating the OSX while working on a project!! ) and i figure after this project i will only use logic x so the logic 8 problem is then not so relevant...

So...i've got 2 screenshots from the Logic X project file.

thanks to anyone else also who might be able to suggest something!!

http://imageshack.us/a/img89/1401/36ox.png

http://imageshack.us/a/img850/4741/o634.png
 

Eli

Logician
FWIW, the problem of the black lines when running Logic 8 with Mavericks is a known issue that others have also reported experiencing. There won't be a fix for it. Logic 8 was released in 2007; long before Mavericks was ever even a glimmer in it's developer's eye. Apple isn't going to release an update to software this old for backward compatibility.
 
Top