Logic Pro 9 Overlapping midi when punching in

Hansverm

Logician
Hi,

when I record midi and play some overdubs with punch in, the underlying regions are still there. When I select the first region again, it overlaps the overdubs, so I won't see them anymore. I have 'no overlap' selected, but this still happens.
After a search in this forum, Google and Youtube, I haven't found a solution to this problem. It's probably something very simple, so please any advice would be greatly appreciated.

thanks
Hans
 

Hansverm

Logician
I'm still having this problem. And I'm not the only one judging from the views this post has got, but no one jumped in to help. I still can't get my head round how logic deals with this, coming from Pro tools. I accidentally recorded two tracks today, one of which recorded over a previous recorded midi region. When I select that region the other one appears on top of it, when I delete it, I lose all my previously recorded midi data from underneath/ the earlier recording. Please, anyone advise or point me to the page in the manual where I can get an answer for this.

Any help would be much appreciated.
 

Eli

Logician
Other than checking that I have the MIDI recording project settings set the way I want (see screenshot), I usually just create a duplicate (MIDI or software instrument) track and record onto that. That way there are no confusing overlaps to deal with; and you can freely edit or merge or mute, etc the two regions independently after the fact.

PS: FTR, the "Merge with selected regions" option requires you to actually select the original region before recording.

PPS: Also take note of the "replace" button on the transport bar. this also effects wether or not punched in MIDI will replace the original data or not.
 

Attachments

Top