Logic Pro X Piano sustain

Tom Senff

Logician
I'm having a problem with a piano part in a recording...... after I record it without even using the sustain pedal, it still sounds like I played the track WITH the pedal, down........ i.e., it does't stop...... is there a “notes off” feature or someway I can make the sustain stop? The weird thing is that it sounds normal when I start the playback right BEFORE the piano solo, but then I get the continual sustain if I start from the beginning.

I just read the posting with the explanation about checking the Event list and couldn't find the event list.......

Thanks!

tom
 

sonnykeyes

Logician
What kind of pedal do you have? I know some of the newer digital pianos have a 'half-pedal effect' so maybe your pedal has this feature? If it's messing you up, you can go to the Environment window and in the Clicks & Ports section insert a Transformer object that will eliminate all the Control 64 non-0 or -127 events.
Screen Shot 2020-03-22 at 5.53.16 PM.png
 
Upvote 0

Hedgehog

New Member
I'm having a tricky issue with my sustain pedal. In the Event List, I'm seeing values in between 0 and 127, so I'm finding that the sustain isn't ever really "clearing" when it should (ie if I have not fully released the pedal, but retained a slight foot pressure on it perhaps). I thought sustain would be either value=0 or value=127 (ie. sustain off or sustain on) - I'm surprised to find values in between as well!
Anyone know what I can do to remedy this? At the moment all my recordings that use pedal are sounding blurry! :(
PS - here's a screen shot of a portion of the Event List. It's very rare that I see value=0 (so the sustain is hardly ever completely turning off) - I managed to find one occasion of it for this screen grab, but as you can see it has loads of in-between values too.
What kind of pedal do you have? I know some of the newer digital pianos have a 'half-pedal effect' so maybe your pedal has this feature? If it's messing you up, you can go to the Environment window and in the Clicks & Ports section insert a Transformer object that will eliminate all the Control 64 non-0 or -127 events.
View attachment 1951
Thank you so much for your helpful response. I have a Yamaha CVP-635, and it hadn't occured to me about the "half-pedal" thing, but I went through the keyboard's menu options and found that the sustain pedal has two modes: sustain switch, or sustain continuously. It had "continuously" selected. I've altered it to switch, and now I see (in Logic's transport panel) only two control 64 values: 0 and 127! Problem solved!! Happy Hedgehog!!! :)))) Thank you again.
 
Upvote 0

tony88keys

New Member
hi I have had the same issue with no luck using the event editor but I did find something that worked for me .if you click on the region and go into the score mode you will see all of the pedal notations just go ahead and highlight them ,then hit delete it should stop that unwanted sustain .
 
Upvote 0
Top