Logic Pro X Please HELP!

Sonichead65

Logician
Anyone know what is the issue here?
I'm running Logic X but having sound issues when recording using my micro Korg via MIDI.
Please see this video for details. Thanks.

 

CSeye

Logician
Hello,
Your video question clearly conveys your concerns.

In your video the sound when recording doesn't sound right. Does it sound ok during playback of the recorded MIDI region?
If so, then the first issue to address is to turn LOCAL off in your micro Korg.

The Korg has "local" sounds built into the unit. When you press the keys you hear the local sound of the Korg but also the MIDI data (note pitch, volume, duration, etc) that is sent to Logic. Logic wants to route that MIDI data to the Korg for playback. The end result is that you may be triggering double notes.
 

Sonichead65

Logician
Hey thanks guys. Its 06:30 at the moment and my studio is in our bedroom. Once the wife wakes up later, I'll check both of your ideas and report back. Cheers.
 

Sonichead65

Logician
Ok guys I tried the suggestions but I'm still getting sound feedback from my Korg. Its easier to supply video as it demonstrates my issue easier. I appreciate your replies guys. Thanks.

 

CSeye

Logician
As a next step in understanding your situation, do the following;
- Reconnect your MIDI In cable.
- Record a brief passage as before but do not delete it.
- Play back the MIDI region. Does it sound ok or not?
- With the MIDI region selected, open the Event list. Is the note data only from MIDI channel 1 or is data from another channel or controller data also present?

Logic has a useful MIDI monitor. To show it, Control-click on the right side of the display as shown in the attachment, then select Custom. The MIDI monitor will not be visible on the right side of the display. You can see MIDI channel number, note name and controller data during input.

You'll need to have audio channels set up in Logic to hear the playback sound from Input 3-4, and to record the audio for your mix.

There may be other issues that are microkorg specific that I can't help you with.
 

Attachments

Sonichead65

Logician
It sounds better, does this correct?


That feedback sound is annoying but I'm not sure if that's something that cannot be corrected?
I only get that screeching feedback when I hit record or playback, maybe obvious but I don't get that noise when I've unplugged the MIDI cables and record only in audio. I could just record using audio but that will mean i wouldn't be able to record arpeggios as the Logic clock would not be syncing with the korg. Thanks again.
 
Last edited:

Peter Ostry

Administrator
Staff member
This does not sound like Feedback. Rather like high notes.

My suggestion:
Install MIDI Monitor. Under the "Sources" triangle, enable the checkboxes "MIDI sources" and "Spy on output to destinations". Now you see almost all MIDI data flowing to, from and inside your computer. Find the annoying notes and their origin. Then we can talk about eliminating them.
 

CSeye

Logician
Just a couple of notes in response to your most recent video.
The reason for looking at the Event List was to determine whether or not unintended data was present, my suspicion was that notes or data from another channel was being recorded. In your case, everything looks good.

When the display is set to Custom, the built-in MIDI Monitor in the transport will give a visual MIDI In and Out of Logic. I always have this on. Play some notes on your keyboard and watch the display.

At this point, follow Peter's recommendation to see what the Snoize MIDI Monitor reveals.
 

Peter Ostry

Administrator
Staff member
MIDI Monitor is a realtime monitor and you are only interested in the moments where those high tones sound. Exactly spoken, when such a tone starts to sound. If it is a note, there must be a note-on message. If it isn't a note, it must be something else but you ought to find it.

Test setup:
Find out the actions that switch the high tones on and off. Record enable, pressing a button, whatever triggers those tones. Leave MIDI Monitor open beside Logic and do repeatedly these particular steps while you watch the messages. If necessary, filter message types until you see the events that are directly correlated to the high tones.
 
Last edited:

Colin Shapiro

Logician
A few thoughts on this problem Sonichead:
- Do you have problems when you trigger Logic's internal sounds (as opposed to trying to trigger your Korg sounds)?
It sounds to me like data is feeding back via Logic to the Korg and overloading everything.

- You get the disturbing sounds while recording, as per your movies above. What happens when you ignore the noise, and then play back the recording? Is there still noise?
Just wondering if the problems are being recorded, or only happen while playing live.

- CSeye asked about what's on your Event list. Is your Event List showing Controller data?
Make sure that [Controller] is "lit" and on in your Event List.

Let us know....
 

Sonichead65

Logician
Hello all.
In response to Colin's questions, I don't get this annoying sound when using Logic's internal instruments, only with my midi attached micro korg. I get the "feedback" sound both when I'm recording a midi track using the Korg and also when I play that recording back. I dont get it if I just play the korg and not hitting record, it only cuts in whilst logic is in record mode. I've ticked controller data in midi monitor and there is data showing but I'm not sure what it is I'm looking at or for? See video below please. Thanks a lot all of you for your input on this matter.

 

volovicg

Logician
So if you just unplug the midi cable going from logic back to the korg - does the issue go away?
If it does then it's a midi thru issue (feedback loop) and we can disable midi thru in Logic
 

Sonichead65

Logician
OK, I've just taken the midi cable that goes from Logic into MIDI IN on my Korg. I can hear the Korg and it sounds great with no extra noise when recording, but on playback there is no sound at all. Presumably as the midi channel is not feeding back into the korg to trigger the sound?
 

volovicg

Logician
Correct and that is the expected behavior. I will be in front of a computer in about 2 hours - I will post and explain a possible solution then.

Are you using an external midi track or an SI track with and external instrument plugin ? Pls confirm
 
Top