Logic Pro 8 PreSonus Firebox 'lets go' of Core Audio

Here's a new puzzle. Does anyone else have this? It almost never happens when I've just turned on the computer, so I think it might be caused by other apps (usually the only other apps I use are Firefox, Quicktime and Entourage) but what happens is: I open up a song in Logic and press Play, and the meters bounce onscreen but nothing comes out the Firebox. It's no good restarting Core Audio from within the Audio Prefs, and even rebooting Logic doesn't usually fix it - I have to restart the computer. My question is, is this an issue with the Firebox, or is my system just wiggy?

Sonny Keyes
Ricochet Audio
You're using the Firebox only for Logic's audio, correct? It's not set as default audio I/O in Audio/MIDI Setup?

I have three audio interfaces... an internal RME card with ADAT lightpipe, a Presounus Firestudio project and a Presonus Inspire 1394. The RME and Firestudio use specific drivers, the Inspire, like the Firebox is Mac 1394 system compliant. The Inspire 1394 is the only one that's ever given me any trouble. it will sometimes glitch repeatedly, occasionally it corrects it self if I toggle the sample rate. I don't know what your system is but the Inspire does best on my G5, OSX 10.5.5 w/Texas Instruments firewire chip.

I've heard you can manually update Apple's firewire implementation by signing up on the developers forum and downloading the latest Apple Firewire26sdk. This supposedly corrects some firewire audio problems but I can't swear to it.

Thanks for your thoughtful reply, Howard. Next time this happens, I am going to try toggling the sample rate (hadn't tried that yet) and see if it wakes up again. I'm still on 10.4.11 on an old G5 2x2GB - don't know what Firewire implementation was standard in it (I'm away from the system now) but I didn't do any upgrades to it, so it's whatever was stock off the shelf.
I've an M-Audio Firewire Solo running on an iMac, and have had the same problem. Everything hums along just fine for....a couple of minutes and then silence. Like you the meters register but no sound. M-Audio site has a number of recommendations and it appears to be happening a lot, but to date none of their fixes have worked. I gave up and just ordered a Focusrite Saffire Firewire - better all around, I hope.
Now what to do with the M-audio door stop.

Does the M-Audio Firewire Solo use the Apple system Firewire driver?

Evidently many devices that use system compliant Firewire are having related problems... doesn't mean it's the Apple driver but some were signing on to the Apple developer site just to download the latest Apple firewire SDK.

Thanks Howard, actually I am not sure. Is there an easy way to check for this?
Updated firewire drivers can be had at the developer site. I will have to check.

Looks like the M-Audio Solo uses a specific Firewire driver from M-Audio... the Presonus inspire and Firebox are basically plug and play, both use the Apple built-in Firewire driver. All the presonus units need is a software control panel application.

I don't know if the Apple Firewire updates will help or not.