Logic Pro 9 Problem recording automation with hardware controller


Hello everybody, I have searched the forum and don't easily see this already mentioned.

I am using hardware controllers to record automation of plug instruments, in this example for the ES2 instrument plug in. The problem I'm having is that after I'm done recording the automation, the automation value of the parameter at time zero of the track becomes the value of the first change instead of the original value at time zero. For example, let's say my track starts at time zero, and at time zero the osc1semi parameter is at 12s. I start to record automation and turn my knob up +1 at time 1. What happens is that at time 1 the automation value is now 13s. This is probably ok. But the problem is that Logic also adds an automation dot at time zero that is also 13s instead of keeping the dot at time zero the original 12s. (And perhaps time 0.9 should also be at 12s and then at time 1 it changes to 13s.)

This happens when using 3 different hardware controllers (listed below in specs). It also happens on many different plugins (logic and 3rd party) and different parameters, and in touch, latch, and write mode. It's happening with knobs, sliders and buttons.

There are two interesting exceptions. First, on my Novation Zero, I can assign the same instrument parameter to both a knob and a slider at the same time. The knob will have the problem above, but the slider will not! Using the slider retains the original parameter value at time zero of the track, as is desired. Another inconsistency is that on the Novation, in 'mixer' mode I can automate the mute setting using one of the predefined mute buttons in 'mixer' mode. This mute button works and retains the original time zero mute value. However, in instrument mode, that same exact button assigned to 'bypass filter' on ES2 instrument will have the same problem above.

I mention these inconsistencies because tell me that retaining the original time zero parameter value is possible.

As comparison, using my mouse to adjust parameters while recording automation works perfectly. The original parameter values are all retained. This is what I want to have happen with all the knobs and sliders and buttons on all my controllers!

Has anyone else experienced this? Does anyone have any solutions? Thanks for reading and any help you can provide!


System Specs:
Mac Pro 2.8 Quad Core Intel Xeon; Memory: 3GB 1066 MHz DDR3
Oxygen 49 3rd Gen
Behringer BCR2000
Novation Zero SL MkII firmware 1.3.14

OS 10.6.4
Logic Express 9.1.5 (1700.9) (32-Bit)
Automap 4.3.0


Are you saying you're not getting initial controller values (value prior to first-change instance) recorded?


Hi tomwinnus,

Considering the use of multiple MIDI controllers, interaction between them and Logic "could be" source of problem (unexpected results).:confused:

However, I would check with the Project Settings/MIDI/Chase parameters that could be involved. Also while you are there, the MIDI Data Reduction option in the Recording pane could also be involved (especially if set On).

Another thing to consider: if the recording of automation occurs before 1-1-1-1, it could be ignored by Logic; the Snap and the recording mode could also be at play here...

As you could see, I am unable to give you a specific solution; various possibilities exist and since I don't have the same gear setup, the troubleshooting becomes even more trivial.

However, I personnally noticed tlhat Novation SL-MKII (Automap) controller is rather capricious when used along with other controllers (such as nANOKontrol, Euphonix MC-Control, Mackie C4, V-Control Pro...), often requiring reinstallation of the Novation drivers. :(

Sometimes, when problem of the kind occurs, restarting Logic or the computer resets things in good working state...:eeek:


Hi Atlas, thanks for your ideas. Unfortunately they didn't seem to make a difference. I tried with only one of the controllers turned on, I tried all different chase checkboxes all checked, or none checked, I tried with midi reduction turned off.

I've since updated my logic express to 9.1.7 but no changes. AppleCare wants me to talk to the makers of the hardware controllers, which frustrates me. I'm betting the hardware folks will tell me to talk to Apple.

Anyone else with any ideas would be so appreciated! Thanks, Tom


I don't think any hardware controllers send an initial value when recording starts, and Logic assumes (incorrectly, as we have seen) that the first value input was the value at the beginning of the song. I have always resolved this by either jogging my controller fader slightly at the beginning of recording to send an initial level value, or going back after recording and manually inserting an initial node into the automation track. If you think about it, it's hard to imagine how a hardware manufacturer could build functionality into the fader to detect when recording begins and have the fader send an initial value at that moment only, so you'll just have to trick your hardware manually into doing just that.


Hi Sonny, thanks for writing. It is helpful to at least hear I'm not alone with this. I would not expect the hardware to send initial values. I just can't understand why Logic doesn't remember the initial value. I've thought about jogging the controller at the beginning of recording, but with ES2 synth there are so many parameters, I can't stand the idea of jogging every single knob and button on the ES2 before recording automation. That's why I liked Digital Performer's Automation Snapshot where one button click would make a permanent node in every automation parameter.

Well, Novation wrote back to me that they'll look into the issue in how it relates to the Zero MKii. THey were able to replicate the problem! So again, we're not alone. THis may give me hope to reach out to M-Audio and Behringer next.

Talk to you later, Tom