Logic Pro 9 Problem with Multi-timbral

cubase1999

Logician
I'm trying to set up Multi-timbral for Kontakt, Stylus RMX and more.
I'm following this guide

To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.

but it doesn't work // it doesn't send the different midi channels to different mixer channels.

It actually doesn't look the same in my Logic as in the Tutorial.

1) When I do it it says Kontakt 4 and Stereo Out in the I/O. It says Kontakt and Output 1-2 in the Tutorial. I guess something has gone wrong there already in my setup.

2). When I add a channel in the mixer it does not say Kontakt in the I/O. Also (not sure if it's relevant) I can only add one channel at the time. New new channel becomes a mono channel. I can change that to stereo and then it's possible to add another one.

It'd be great if someone have some tips about what I might be doing wrong!
 
Last edited by a moderator:
Did you configure the outputs (st.1-2; st. 3-4; etc) in Kontakt's mixer? This needs to be done in order for Logic to see them.

Are you clicking on the + symbol on the Logic instrument channel strip where Kontakt is inserted to create additional aux channel strips for your Kontakt outputs? If you've configured discrete outputs in Kontakt as above, then this step will automatically assigns the next available Kontakt outputs to each new aux channel strip.

If the above doesn't solve the problem then it would be helpful if you could attach screen shots of your set up.
 
Upvote 0
I think I've noticed one mistake I did now. I have to choose Kontakt 4 from the I/O and Inst 1 in the mixer, right? I still only get two different Outputs though as there's not more choices in Kontakt.
 
Upvote 0
When you inserted Kontakt, did you choose one of the muitiple output options? See attachment.

This is the most critical step in the whole process as it now allows you to configure the outs in Kontakt. See attachment where for example, the outs for st. 3 are being configured.

Once this is done, then the Kontakt outputs will be assigned in sequence as you click the + on the instrument channel strip. See attachment. (The 3rd channel strip says 4. What can I say? I have fumbly fingers when keyboarding:D)

Here's an old link posted when I was trying to configure all of this in my head... https://logic-users-group.com/forums/threads/what-kontakt-output-configuration-are-you-using.2301/
 

Attachments

  • K m.o..jpg
    K m.o..jpg
    24.9 KB · Views: 177
  • K config.png
    K config.png
    23.7 KB · Views: 162
  • kontakt.png
    kontakt.png
    89.9 KB · Views: 164
Last edited by a moderator:
Upvote 0
Delete the Surround Channel.
You already have 2 stereo channels. 16-2 =?
Mono is one channel, Stereo is made up of_____
Since the two existing channels are using (1&2) of both st.1 and st. 2 , select the first Surr. 5.1 option and click Ok.
 
Upvote 0
Back
Top