Logic Pro X Re-Learning Logic

jpaudio

Logician
Well I have been reading the manual completed the Logic Studio Course. I am going through the Groove3 videos and am learning a good bit. I have my Artist control & Artist mix prefs set up and starting to feel better.

Then I start to record my audio and it stops after 1 or two bars. I do not have the loop record on. I created a new project and it was recording fine with my external instrument. (midi track and audio track) then on the second take, it will not record past 1 or 2 bars.

Any ideas or obvious things I might be missing?

I have my catalina drives formatted for new format. I have an external SSD arriving this week, but my current external 7200 should be fine for just one track of audio I hope.

Thank you for any ideas or triage ideas.

Jeff
 

jpaudio

Logician
Sounds like maybe you inadvertently have auto punch enabled.
Hello, I double checked my settings. When I record audio everything appears good, pops out of record mode. When I record midi, the record function seems to disengage at random places. I thought it was just like a one or two bar loop, but I do hear a crackle and then it pops out of record and starts to play what I have recorded so far.

I tried just my count in and then just let it record with out playing midi. Sometimes it will run a bit but then it appears to randomly just pop out of record for midi only. If I do play midi while trying to record, I do hear a crackle/pop then it goes back into play mode and starts where I started my midi recording take started.

I checked my settings and even CPU. All appears fine on that end. I have gone through a few Logic courses including most of the Groove 3 courses and have been reading the manual, but still no obvious reason whey midi recording pops out of record mode.

My midi devices appear to work fine in Pro Tools and I checked my MOTU Express XT just to be sure mid was working properly.

Thank you for your help and everyone in the forum.
 
Upvote 0

jpaudio

Logician
I just tried playing a midi track I recorded for a few bars before it pop out of record mode. The midi track will randomly just stop and go back to the beginning of the region and then play until it randomly pops back to the beginning of the region again. I do not have loop on too. I noticed high CPU when I was play the midi controller.
 

Attachments

  • 20210108hb.mp4
    1.9 MB · Views: 0
  • Screen Shot 2021-01-08 at 10.10.02 PM (2).png
    Screen Shot 2021-01-08 at 10.10.02 PM (2).png
    29 KB · Views: 5
Last edited:
Upvote 0

jpaudio

Logician
I tried a few changes which fixed the high CPU load and random stops for recording midi. The concern is that I had to go with minim tracks, high buffers and less sample accurate automation settings. I can use these for general music composition but when I start getting a higher track count with drummer tracks I am not sure if my 2013 macbook pro 16 gigs memory, i7 with SSD will cut it.

I can record now without the high CPU after the setting changes below.

Any advice is appreciated.

Thank you, Jeff
 

Attachments

  • Audio-General-Prefs.png
    Audio-General-Prefs.png
    108.1 KB · Views: 7
  • Sampler-Virt-Memory.png
    Sampler-Virt-Memory.png
    90.8 KB · Views: 6
  • Audio-Devices-Prefs.png
    Audio-Devices-Prefs.png
    111.6 KB · Views: 6
  • High-CPU-B4-Changes.png
    High-CPU-B4-Changes.png
    51.8 KB · Views: 4
Upvote 0

jpaudio

Logician
Sounds like maybe you inadvertently have auto punch enabled.
Hello, I have been watching most of your videos and they are helping a lot. I am posting this reply because I dug a bit deeper into my midi recording issue. It is a high CPU issue. I was at 128, and recorded audio fine, but midi had to be 512 or 1024.

If you have time, no rush, I added some screen shots above and made some changes. I am able to record midi now, but with high buffer sizes and reduced features. Any ideas or work arounds are greatly appreciated.

Thank you,
Jeff
 
Upvote 0

jpaudio

Logician
I just finished the adjustment in groove3 video "Setting the Record Delay" Not the best settings but now my audio lines up. Very good video.
 

Attachments

  • Setting the Record Delay.png
    Setting the Record Delay.png
    108.5 KB · Views: 4
Upvote 0
Top