Logic Pro 9 Recording from AUX - No Audio Waves Appearing


I have started noticing the same problem - its very annoying when working with clients and tracking on the fly.
1st - I only have this issue when I am recording from an aux channel.
(for example - I track guitar, one track is recording the dry signal - (which is being sent to amplitube2 on the aux - // the output of the aux channel is set to a bus - and then a stereo track is record enabled with its input set to the effected signal.)
Interestingly - the dry guitar works perfectly everytime - the audiowave shows up fine -every time - Typically Audio-Refresh-Overviews - will get the remaining audio files to show up - but in the past week - ive noticed that several files wont refresh - the audio is there.... but notinh visible.
I've tried creating a new track - and then pulling the wave out of the Bin, to see if that would resolve - but no luck.
If I bip the region - the new track will show normal - but as there are lots of gtr edits to do - thats not an option.
So from my experience - this seems to completely stem from audio tracks whose record inputs are assigned to AUX channels.

I have not tried the plist solution - but thought we could reopen this discussion - as it seems a viable concern for us.

running logic 9.1 / Mac OS 10.5 / 2.8 Dual Quad Core
MOTU PCI-e 424 / 2408 mkIII, 24i/o, 308, 2xApogee Rosetta 800
Dangerous 2BUS