Logic Pro 9 recording hangs ...

... running an octane via lightpipe to motu 896HD. When I select the tracks in Logic Pro (11 and 12) arm both (recording to two mono tracks) and select record, Logic hangs with the pizza of death ... eventually it starts recording (after about a 30 sec delay - no count in click can be heard) ... anyone experienced something like this?

macbook pro 2.4ghz
Logic Pro 9
Motu 896HD
M-Audio Octane
Maybe I'm asking an unclear problem? I would find it interesting if I'm the only one to have experienced this?!? I have searched this group and the net and cannot find reference to a response lag after pushing the record button. To my mind it would seem like a memory issue, but do you think that there may be a 'setup' issue in Logic Pro that is causing this?
And/Or also: do you prefer chocolate or vanilla?

I tested with a 002r and the same thing. set up your project, arm your tracks and record (first record will SOMETIMES work normal) 2nd time you hit record and the system hangs for about 20 secs then starts recording .... no one ever had this happen? I've trashed prefs, made sure drivers are the latest ... etc.

P.s. Pro Tools works fine ....
It is a Logic Pro 9 bug. Logic Pro 8 works fine. I'll just stay away from Logic Pro 9 and use Logic Pro 8.
Thanks for the help guys, I hope you don't experience the same thing.


Try using the built in Mac core audio engine and testing it in a default empty project and see what happens. This will remove your Octane and any potential sync or driver related issues from the equation; as well as possible project corruption. What you are experiencing is definitely not normal.
Thanks Eli, I did as you suggested and the result is the same. I disconnected everthing from the macbook pro and selected 'built - in audio' for input/output. The first time you press the button is fine - the second time it hangs. You have to restart the program to get it to work (for the one time only). It does this in 9.1.1 and 9.02 .... Logic 8.02 works fine ... I don't know if a re-install is required here?


Have you tried trashing your preferences? And also - you didn't mention specifically if you did this or not - make sure to try the test from a brand new "Empty Project" from the factory templates.

If you have used an empty project and trashed your prefs, than I'm out of ideas at the moment :brkwl:
Hi Eli, love the 'smiley' at the end of your post :) Yes, I trashed the prefs from my home/library/preferences/ ... I'm not aware of other locales? I am starting an 'empty project' from the 'new' menu of logic .... I don't want to remove Logic 8 (it works!) but I'll try re-installing Logic 9 and see how that works ... I'll keep you posted!
also be aware that if Logic 8 and 9 are on the same computer/user, they share preferences. I'm not sure to what extent, or if this has been modified since 9.0.
wow. Doug, I'm currently listening to you on 'music production in Logic 8' DVD! You and Eli do some great instructional work! There may be too much interplay with stuff on my macbook. Right now, Logic 8 works great. I'm going to clean my computer, reinstall the OSX and then clean install logic 9 to try to figure it out (I also recently upgraded to a larger hard drive (5400 rpms). I run both digi and motu hardware, in addition I purchased some soft drums (steven slate ..) and that may be the last time that I used logic 9 successfully ... ? ... Throw on an old copy of Reason (4) that I haven't really used, and I think the message may be to keep the system 'clean' and carrying only what you use. I'll keep you posted!
That's scary - I'm in two locations on your computer! Another reason to clean things up!!!

Actually - thanks for the kind words - speaking for Eli as well (if I may, Eli), we both work hard at these products and they really don't mean much if they can't help the end user.

I think your plan is great - never hurts to clean up things. Make sure your hardware drivers are current - digidesign is especially slow in upgrading to a new Mac OS release (a question - does the project crash regardless of audio interface used? You have three: system, MOTU and digi.)

Maybe wait to install the Steven Slate plug-in until you know things are working, then add it (maybe back things up first...). And, do post results, thanks - it helps everyone.


Like Doug says - glad to hear you are enjoying the videos! It really is very gratifying knowing on a personal one on one level when specific people are finding them useful and helpful.

Having said that - I thought of another thing for you to try before going to the all the work of a complete re-install. Why don't you try disabling all of your third party audio unit plugins temporarily. It's easy enough to do with the Audio Units Manager available under the preferences menu. And it will rule out the possibility of any third party plug in incompatibility relatively painlessly.
I reinstalled L9 along with the OS ... it now works. I'll carefully install my other software and check Logic after each (tedious) in order to determine a conflict ... if I find something I'll let you know. Thanks all, I appreciate your help much!