Logic Pro 8 Roland JV-1080 cards not "seen" by Logic 8

Colin Shapiro

Logician
Just to be clear:
The Environment Window can display EVERYTHING in your Project: Audio faders, Instrument faders, Bus and Aux objects, and the Multi-instr objects we're talking about. These objects may all be on one layer or spread across several layers. Look at the Inspector for the Environment Window - it will display something like [Layer: Audio] or [Layer: Mixer] depending on what you have configured. The Mult-Instr object you've made for your XP50 represents all necessary parameters for that piece of hardware.

I do recall in old versions of Logic that there was a limit to the number of Banks that you could configure - not sure if this is still the case in Logic 10.2
 

avilall

Logician
So once all the MSB/LSB info is entered in the window, then when I go to to Multi Instrument window where all the patches are entered, the Bank Message drop down should show Roland XP50 along with other synths listed there? And also in the Bank window above that, the drop down should show all the 11 banks I made? I don't see either of them. What am not doing correctly.
 

avilall

Logician
Guess I am making progress. I can play the software instruments in Logic from my XP50. I can send MIDI data from Logic and play it out on the XP50. But I still can't address the Patch banks on XP.
 

avilall

Logician
Guess I am making progress. I can play the software instruments in Logic from my XP50. I can send MIDI data from Logic and play it out on the XP50. But I still can't address the Patch banks on XP.
No, I take it back. I cannot send MIDI data from Xp and pay it out. I was playing it back on the software synth and got confused. !!!!
 

Colin Shapiro

Logician
So once all the MSB/LSB info is entered in the window, then when I go to to Multi Instrument window where all the patches are entered, the Bank Message drop down should show Roland XP50 along with other synths listed there? And also in the Bank window above that, the drop down should show all the 11 banks I made? I don't see either of them. What am not doing correctly.
No. It will simply show *Custom Bank Messages*. Unfortunately there is no way to name your new set of parameters and add it to the list.
No, I take it back. I cannot send MIDI data from Xp and pay it out. I was playing it back on the software synth and got confused. !!!!
Have you set up the Port and Channel for the XP50 in the Environment?
Is the XP50 configured in the Audio MIDI Setup app?
 

avilall

Logician
Yes, XP50 is configured in Audio MIDI Setup. However, in the Environment, which channel should I select? I want the XP to be available on ALL 16 channels if I want to do a sequence based only on XP and no software synth.
 

avilall

Logician
Yes, XP50 is configured in Audio MIDI Setup. However, in the Environment, which channel should I select? I want the XP to be available on ALL 16 channels if I want to do a sequence based only on XP and no software synth.

Logic still not outputting to Roland XP50. Done with making the 11 Banks as well as the MSB/LSB table. Audio MIDI setup is fine. In fact, I can play my XP50 and record in Logic. I can also play software instruments in Logic from the XP50. But when I send a MIDI track out from Logic to play on XP50, it doesn't play. As a test, when I connect the XP50 to my Win XP machine and a legacy sequencer, the MIDI tracks play fine on the XP50. When I connect the XP50 to Logic, no output. [the XP50 audio out is routed to my external speakers via a mixer.] SO I think the issue may be with the External MIDI instrument setup in Logic. Any ideas?
 
Top