Logic Pro 9 Score Editor forcing note values I don't want

marksealey

Logician
I have a piece with four Tracks (one Region in each) all set to a 4/4 time signature. Actually, they each start off 6/4. I have dropped 4/4 on all tracks at measure 25.

One Track refuses to accept and beam eighth notes dragged from the Part Box into an empty measure - even though I have several measures in another track quite happily populated that way.

Is the position of where I drop so precise that, try as I might, I cannot get it right? Have tried both with Interpretation on and off. They're not dotted eighths... have been caught that way before!

(Still finding my way around the Score Editor; apols for asking what may be obvious!)

Thanks!
 

Eli

Logician
I seem to recall there is a "beam selected" command under one of the score editor menus (I'm not in front of Logic at the moment). Take a look around for that.

In terms of where and how you drag notes in, there should be a yellow info tag showing the exact position when you release the mouse. Keep your eye on that. And set your grid division to something useful (like 1/16th notes" so the note placement will snap to those divisions; making placement easier.
 

Ginger

Logician
One Track refuses to accept and beam eighth notes dragged from the Part Box into an empty measure
Hi, what do you mean by "do not accept"? What specifically happens?

There's a separate quantize parameter for the each region in the score -how is that set, and how is the quantize value set in the Arrange window?
 

marksealey

Logician
Eli,

Thanks! I'm not at Logic atm,either: shouldn't it beam automatically?

I thought I had division at 1/16... the default, isn't it?

So shall try again tonight - appreciated :)
 

marksealey

Logician
Ginger,

Thanks. I drag an eighth and Logic changes it to a quarter when I release the mouse - etc.

I've seen that happen when Logic knows that the note can't fit... changing a whole note to a half when there's already a half in a 4/4 measure, for example; and assume this is something similar.
 

Ginger

Logician
I thought I had division at 1/16... the default, isn't it?
Division is something else.... Look for Quantize in the upper left corner of the parameter area in score.

Beams should happen automatically unless you have told Logic to use Vocal mode (in the Staff Style window).
 

marksealey

Logician
Thanks, Ginger; shall look again tonight and see whether I have such a rogue setting. And ask again if still no go, please. The odd thing is that Logic beams other tracks in the Project as I would expect. Surely the Time Signature has to apply to all Tracks regardless?
 

Doug Zangar

Logician
Use the event list to look at track contents. It's possible you have a user rest or doubled notes.

There are numerous ways to deal with the beamed notes setting. You have the staff style window, the attributes menu and the attributes pop-up window. Possibly you did something there.

Consider posting your file to have it looked at.
 

marksealey

Logician
Ginger,

Quantize is set to 4,6 in top left (Inspector). Can't see a 'Vocal' parameter in the Staff Window; doubt very much I could have set it that way.
 

marksealey

Logician
Doug,

Thanks too for helping!

I attach screengrab of what's happening after I've checked that the beam settings are the defaults in the places you suggest.

Eighth note selected in Part box. Dragged three times to bottom (4th) track at measure 20. Logic first puts in quarter notes, then groups them with 3.

Will happily post; most grateful. A zip? It's 360K.

Much appreciated.
 

Attachments

Eli

Logician
Hey Mark,

It's treating them as quarter note triplets. That doesn't have as much to do with the note durations you are dragging in as it does with the position you're dragging them too. I can't see your score quantize settings in that screen shot. But if it is set to something with a 6 in it; it is easy to see how this mistake could happen; since 6 is the division for quarter note triplets when working in a time signature with 4 as the denominator and a 4, 6, or 2, as the numerator.

It looks like you just dragged them in to the incorrect positions. Try re-dragging them in and keep your eye on the info tag. Or you could try quantizing them to eighth notes using the score Window's quantize tool.

As an aside, here's a screen shot of that command I was telling you about before; although it doesn't seem like this is the root of the problem in this case.
 

Attachments

Doug Zangar

Logician
Welcome, as always....

Your screen swipe is a little hard to read.

Not sure what file size restriction is - you'd have to check it out when you attach it. I know moderators kindly increased maximum file size in the not to distant past.

Alternately, feel free to e-mail it to me. Zip is always good.

Lastly, (as a work-around) you might try copy/paste from track one to see if those stay as 1/8th notes. You could then assign them to proper pitch.
 

marksealey

Logician
Eli,

Thanks; and thanks for the beaming menu ref/grab. I'd prefer to have Logic do it itself since I know it can and is supposed to.

I suspect quantization now too. It's (been) set to 4,6.

I've been very careful in dropping in just the right places to make sure - using the info tag as you suggest. Doesn't seem to make a difference, although I do appreciate how critical that is. (How do I set Division of measures - to show it, btw?)
 

Doug Zangar

Logician
Got the file. Most certainly your quantization setting. Sent you an e-mail back, but posting this to let others know the problem.

Edit: the reason it worked on track one is your score display quantization is set on 64, enabling the display of 1/8th notes. The track in question is set at 4/6, allowing only 1/4 notes or 1/4 note triplets.
 

marksealey

Logician
Doug and others,

That's it!

Thanks so very much for your patience. Am obsessed with Logic in such a way that I hope to be able to put in as much as I got out soon :)
 
Top