Logic Pro 9 Setting EXS 24 Loop Points Broken?


Hi All,

I have a repeatable problem that, unless I am doing something wrong, indicates that setting the start (and end) position of the loop points in the EXS 24 edit window is broken. Okay, here's what I have tried, and my results (the third point below illustrates the problem):

* I created a new sampler instrument and loaded a (Wav) file in as a zone.

* I enabled the view for all the parameters in the instrument editor so that the loop parameters were visible.

* Control clicking on the start point to open the sample editor did not work as expected.

* Clicking under the zone name field to open the file in the sample editor did work.

* In the sample editor I then shortened the zone to be the length I wanted.

* I enabled the loop functions from under the sample editor's "Edit" menu.

* I adjusted the loop marker (green bar) to taste and closed the sample editor.

* I enabled the loop check box in the instrument editor.

* The zone triggered and looped as expected.

* I repeated the same experiment with an aiff file - just to rule possible file format inconsistencies; and had the exact same results.

* Conclusions: Access to the sample editor from the loop start point field seems to be broken. But it is easily worked around by accessing the sample editor from the zone field in the instrument editor, and then manually invoking the loop function in the sample editor.

Can anyone else confirm or corroborate that accessing the loop start point parameters by control clicking in the "start" field is broken?
The sample editor opens in a separate window when I right-click on Loop Start in the instrument editor.

I do notice that the Sample editor tends to get lost behind the large screen-space-consuming instrument editor. But it was there.

On the other hand, when clicking on the Zone name to Open In Sample Editor, it opens the Sample editor at the bottom of the consolidated window below the Arrange area.

Maybe it's a matter of floating windows getting lost in the shuffle.

Upvote 0
Hi CSeye,

I checked again and the behavior is inconsistent (on my system at least). Control clicking in the start field of the loop parameters didn't invoke a sample edit window. Most of the time! After doing it many times, finally it did once. I couldn't repeat the behavior though. Repeatedly control clicking for the sample editor to set the loop start point eventually crashes Logic here.

I made sure to move and resize my windows to make sure it wasn't lurking in the background. As I say, one time it actually did work as expected. I tried different combinations of having the Arrange and/or EXS Plug In window open/closed. Nothing provided consistent results though.
Upvote 0
Hi Eli,

Very strange.

I should start keeping a list of little annoyances that occur from time to time.

A current example: In the Hyper Draw pop up Other window, I should be able to select an item then use the up and down arrow keys to scroll through this long list of controllers. No dice. I have to manually click on the on-screen scroll bar/arrows.

Upvote 0
I agree that would be great - scrolling in hyper draw's "other" list. But I think that falls more under the realm of "unimplemented feature" rather than that of "bug" or "broken".
Upvote 0