Logic Pro X Smart Tempo not behaving very smartly

#1
Is it just me, or is Smart Tempo buggy as hell? If I open a new project and turn on Smart Tempo, set it to “follow bars and beats” and then import an audio file, the behavior is totally, randomly inconsistent. For instance, some files will be analyzed when importing and the tempo will adjust itself to the tempo of the imported track, the flex markers will be there, the file plays perfectly with the click. With other files, nothing happens. Or maybe it does, sometimes. I’ve imported the same file several times with varying results. I had one that turned it into 6/8 time and another time kept it in 4/4. Ive tried setting it to “Keep” and “Adapt” with the same inconsistencies and “maybe this time” results.



I’ve noticed that I seem to have the most trouble when importing an audio file that was bounced out of another Logic project. Sometimes the new project will ask if I want to import the tempo information that’s in the file I’m importing, but whether or not I opt to do that, the results are nearly always that nothing happens, i.e., the file is not analyzed, no Flex markers, etc. Or, once in a while the song plays back at much faster (or slower) speed. I’ve tried deleting the tempo information from the file before importing, but it didn’t change anything as far as I could tell.



I can’t be the only one experiencing this, but I haven’t found much online about these issues. I’ve been careful to follow the steps (new file, setting Smart Tempo in Project Settings, etc) carefully but each time the results are completely unpredictable. I’d really like to know if anyone else has had this happen, and what I can do about it!



3.4 GHx Intel Core i5

24 GB RAM

OS 10.13.6

Logic 10.4.1
 
Top