Logic Pro 8 Sudden loss of sound on Logic 8 + MBox2 Pro


I run Logic 8 with the MBox2 Pro and a MacBookPro 2.33 GHz, 2 GB RAM and Tiger 10.4.9.
Normally this system works really well. However, since yesterday, when I open a Logic song, everything plays fine, until I perform any simple task, such as switching tracks or loading a plug-in, etc. Then the sound disappears. The level meters are still going, but there is no sound.

If I restart the computer, the sound comes back, but only briefly, until I start using the program.

This problem also seems to apply to QuickTime Player, iTunes, etc.

This is a first for me and I would really appreciate if anybody could help sheding some light on this matter.

Thanks in advance for your assistance.

Q: Is it a specific logic song, or all Logic songs?

If it is a specific song, I see this happen every now and then after I add a specific plugin to an existing song. No idea why, it just seems to happen...

Upvote 0
Hey Michele, I had similar symptoms with my PreSonus Firebox - eventually I figured out that the FB was losing its FireWire connection, and re-seating the FireWire cable (I used a different port on the computer) solved the problem. Here's hoping your issue is cured as easily as mine!
Upvote 0
I can say that this must be a specific issue to your system, due to the fact that I also have a Mbox 2 Pro, and use it on a Mac Book Pro, Mac Pro, G5, and my PC; all with no major issues to report.

I agree with Sonny, try a new Firewire cable.

Q: is your Mac set to auto software update? I wonder if a new version of QT might have busted the audio. I've seen that happen in the past as well.

If so, I'd suggest looking at the Digi site to see if there is a newer core audio update for the MBox. that might fix the problem.

Something must have changed on your system though. this kind of issue, where a system suddenly changes behavior, is either a software thing (somethings changed or been added) or a hardware failure (your system was moved, and the cables were reseated).

Good luck... this stuff can be a bugger to figure out.

Upvote 0
Problem solved!
It was a matter of Disk Permissions. Don't ask! I just followed some instructions and miraculously, the system was working again.

Thanks again for your advise.

Best to all.
Upvote 0
Well that one has me gobsmacked!

I would have suggested this for a number of things but not this (as seem by my suggested solutions). Man, I'd really love to understand why this is...

Anyone who is more tech than I have a suggestion?

Upvote 0