Logic Pro 9 Tempo change bug using midi


I get problems with external midi when changing tempo on Logic 9 on Mac OS 10.7 (Lion). From other user's I've learned the bug does not exist on OS 10.6 (Snow Leopard). I would be very interested if anyone using Logic 9 on Lion can reproduce this bug.

This is how to discover the bug I get.
(I've enclosed the project below in post #4)
- Tempo 120
- Make an external midi track triggering some percussive sound on a midi hardware unit.
- Prorgam one bar with constant 16th notes (or 32nd notes).
- Make this region a loop.
- At some bar set an abrupt tempo change to 60.

When tempo change is played back the 2nd and 3rd 16th note (in the bar whith the tempo change) are not played back properly in time, 2nd too early, 3rd seems too long. It's very easy to hear, it's a huge timing glitch.

I tried two midi interfaces getting the same result.

Midi unit is a Clavia Nord Modular but I'm pretty sure the problem is not in the midi unit because I don't get the error using a MPC Sequencer or with my old Loic 8 on G4 and Mac OS 10.4 and same midiinterface.
There's no midi clock or MTC transmitted, just pure midi on/off.
There's no other midi or audio applications and hardware running.

Same programming on an instrument track within Logic will play back correctly so the bug is only with external midi.

Logic 9.1.8
Mac OS 10.7.5
Mac Book Pro 2.2 Ghz i7, 8 gig RAM
Audio: MOTU 823 mk III
Midi: ESI M4U and MOTU 823 mk III
It is a Logic Pro bug, and if you want an internal midi/VI to play it back correctly, you will need to freeze the track.

But internal midi tracks (that is a virtual instrument) are played back correctly in my system. I'm having the problem only with external midi. Unfortunately freezing the track is not possible in this case.

Also it's not just a Logic Pro 9 bug since I've had numerous reports of Snow Leopard users who aren't having this problem on 9. What I don't have are reports from Lion or Mountain Lion users whether they have the bug or not.

Which system are you on and do you have the bug on external midi as well as internal midi?
Upvote 0
Here's an exampleproject with the tempo changes.

Please, if you have Lion (or Mountain Lion) and external midi equippment. Please record the output from the miditrack. I'm really interested in hearing if you get the same error when tempo changes.


  • TempoBugProj.zip
    179.1 KB · Views: 194
Upvote 0