Logic Pro 9 The all too familiar recording delay


New Member
I've been using Logic 9 for over a year on my macbook and have had no problems with a delay in vocal or instrumental recordings before. I use an audio box and a Rode NT1-A Microphone to record to Logic. Although I have fiddled with Logic and programs like fruity loops for over 5 years I'm still not a pro, I'm not skilled in the technicalities like this that come up and have no idea what the problem is except for the fact that it's likely a problem with latency.

What I'm confused about is why this just started being a problem, when every other song recorded has worked like a charm.

Processor Speed: 1.83 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 2 MB
Memory: 2 GB
Bus Speed: 667 MHz
Boot ROM Version: MB11.0061.B03

System Version: Mac OS X 10.6.6 (10J567)
Kernel Version: Darwin 10.6.0
Boot Volume: Macintosh HDD

My I/O Buffer size has always been at 256, though the recording delay, I think, may have been mixed around by a friend of mine who was playing around with Logic. It's at -1000 samples right now when I was sure it was around 2000 last I remember (could be wrong, naturally).

So how many samples SHOULD I be at? Or what other changes might fix this?

I might as well also mention that I am recording vocals to an instrumental sent to me from a friend, while normally I compose the beat in logic myself, so I was also thinking it may have something to do with Logic trying to automatically correct a tempo that doesn't need to be corrected.

Thanks in advance.

I'm pretty sure it's either a liner phase EQ or a multipressor on an insert on a channel strip, bus or your main output.

please check, and if it isn't one or the other, let me know and I'll think of other things.

One thing I don't get: the I/O buffer is 32, 64, 128, 256, 512, 1024.... not -1000 or 2000. Are you talking about the record offset, which is usually set to 0 on my system (and I use a cacophony or audio interfaces)...
Upvote 0
The recording delay I use is -72, but I don't think there is a "standard". When I switched from a MH MIO to Apogee Ensemble, I had to change it, and the best method I know of isd to play a click and record it (either looping back on your interface or putting a mic in front of a speaker), then see if the recorded audio lines up with the click, and if not use sample editor to see how out it is.

I think it's most likely to need to be 0 or a negative value depending on your interface.

I'm not sure if it needs to change if you change the buffer size, so it's worth checking at different sizes if you change them for recording.
Upvote 0
Like I said, I'm not good at actually utilizing the tools, and I don't really know what I'm looking for with the sample editor and what to do once I'm looking at the tracks.
Upvote 0
^You click and drag from the nearest beat(where click should've been) to the beginning of your audio wave (zoomed in) and a box will show up telling you how many samples there are.

So I just checked mine (recording delay) software monitoring OFF. Mic held right up to speaker with click playing. I had to set mine to -501...Seems like a lot to me. My interface is a motu 828mk3 (no usb) and it was also an empty project.
Anyone.... is something else wrong here. Others with same interface are you getting the same thing or did I screw something up here.
(I've found that 90% of the time it's my error):redface:
This does explain alot of my problems.

Upvote 0
Ok, here's a rough and ready guide.

Play a click track (eg from klopfgeist).

Record it with a mic in front of your speakers (when recording you need to make sure there is no output on that track or you will most likely get feedback)

Play them back together. Do you hear them playing simultaneously (ideally witha sort of phasing sound)

If so all is well.

If not:

Go into the sample editor of the track you recorded and zoom right in.

Make a selection between the exact beat and the nearest waveform click (it may be earlier or later). At the top right of the SE you get a readout of how many samples the selected area is.

Set that as your recording delay (+ or - depending on if the recorded audio shows earlier or later than the actual beat (If later use - in front of the number of samples)
Upvote 0
The recording delay is slightly different for each of three Apple computers I use, but I also have three variants of Logic installed.

To begin with, it you don't know why you would want to set this parameter, you probably don't require it. AFAIK, it corrects the discrepancy in the arrange window created by the hardware latency between your interface and your CPU. It becomes important when you have multiple overdubs, and then start slicing up your tracks. If it is set right, you can whack an audio or MIDI track, slide it into other tracks, and your composite track will be seamless, as near to perfect as the software allows.

My most recent system is a Nehalem quad core Mac Pro (2.66) with only 3GB ram. It has hyper-threading, so applications think there are eight cores. That runs Logic 9.1.3. With the I/O buffer at 128MB, the "recording delay" is set at minus 38. It is not an audibly noticeable tweak, but it means the arrange window displays subsequent audio tracks sample accurate to the original playback track. You can verify it is on the nose by zooming into the arrange window as far as it will go, and comparing the samples in the original and overdubbed tracks.

For comparison, I also have a quad core (PCIe) 2.5 G5 (last PPC version) with 8GB running Logic 9.02. Its I/O buffer is also set at 128MB but the recording delay (to achieve the same result) is set at minus 30.

Both the above systems were using an Eleven Rack (Avid) interface with software monitoring on.

The third system is a G5 dual CPU 2.3 (PCIx) with 4GB memory. It is running Logic 8.02, but has a MOTU PCI-424. Its I/O buffer is set at 512 MB, but software monitoring is off (the MOTU card allows near zero latency monitoring through the interfaces connected to the DSP enriched PCI-424 card). Its recording delay is set at minus 68 samples.

I also have a ProTools HD setup. The HD cards automatically correct for this hardware latency.
Upvote 0