Logic Pro 9 Time pitch mach to 170bpm does not fit Tempo 170bpm

#1
First of, thanks to anyone who helps.

Here is the goal: Time compress an audio file to get the typical drum and bass breaks sound.

Steps I took:
1. recorded audio of a breakbeat created in UltraBeat for 2 bars at 120bpm.
2. copied and pasted audio file into new track.
3. converted copy to a "New Audio File."
4. edited the orignal audio region with Time and Pitch Machine (TAPM), changing the tempo to 170 bpm
5. edited the copy with TAPM also, changing the tempo to 170 bpm and the pitch -24 cents.
6. set the Tempo of the project to 170 bpms.
7. Audio regions fit perfectly in 2 bars and plays for 2 bars, in sync with everything that is not an audio region.
8. Finished session and saved.
9. Next day, opened project. Audio regions are now shorter than 2 bars at 170 bpm. Plays in sync at 185 bpms.

What happened? I can't figure out how to make the audio regions fit in two bars without increasing the tempo to 185 bpms --without having to use TAPM again of course. But I shouldn't have to.

Any suggestions to fix this problem? Anybody else seen this before?
 
#3
I haven't tried converting sound files to appleloops but it appears that the issue was related to my audio/midi in/out device, m-audio audiophile usb. Re-booting the computer and allowing the m-audio driver to reinstall fixed the problem.

thanks for the help.
 

Markdvc

Administrator
Staff member
#4
9. Next day, opened project. Audio regions are now shorter than 2 bars at 170 bpm. Plays in sync at 185 bpms.

What happened? I can't figure out how to make the audio regions fit in two bars without increasing the tempo to 185 bpms --without having to use TAPM again of course. But I shouldn't have to.

Any suggestions to fix this problem? Anybody else seen this before?
That sounds very much like a sample rate issue. If you created an audio file at 170 BPM at 44,1 kHz, playing it in a project running at 48 kHz will adjust its tempo to pretty much exactly 185 BPM. Check your project settings for the audio sample rate you are using.

kind regards

Mark
 
Top