Logic Studio apps Using Space Designer in WaveBurner

Lotus 7

I use Space Designer in Logic Studio with custom IR files with no problems - it works exactly as expected.

I recently was mastering a complete CD in WaveBurner (1.6.0) and wanted to add a little SpaceDesigner reverb to a track. When I try to load an IR, I can't get the normal Mac directory window. Space Designer works on the files, but only has the synthesized IR available. When I click on the "Load IR" button a pop-up window appears, I select "Load IR" (or any choice) and nothing happens (no directory path window). I can change the synthesized IR sample duration.

As I said, in Logic 9 it works fine. All the Apple supplied, and all of my custom IR's are able to be selected from the directory window.

Otherwise WaveBurner works perfectly as does Space Designer in Logic 9.

Is it possible to load IR's in Space Designer when it's being used as a plug-in in WaveBurner, and if so, how?


Doug Zangar

I was curious and just tried this - it seem to work here.

Are you able to load find/ factory settings? You access that in the Setting column, not on the Space Designer interface.

When I click to load IRs on the Space Designer interface I get the same finder window as inside Logic as well, but doesn't point me to factory settings.

Lotus 7

Thanks much for trying it out. Looks like I must have a bug.

In Logic i get the normal finder window every time. I have all the IRs located in the original folder that Apple uses during set up:

Macintosh HD; Library; Audio; Impulse Responses
Works great. Even long IR's load and run in less then one second

When I load a Space Designer plug-in in WaveBurner, I get the usual drop down menu;
Load IR
Load & Init
Show in Finder

But when i select "Load IR" the drop down menu disappears and that's it. No finder window opens, so I have no way of pointing Space Designer to the folder that contains the IRs. I even tried reducing the size of the S.D and full WaveBurner windows to check if the finder window was behind them, but it's not there.

Tried it after restarting and reloading the applications, and tried it with several different projects, and the finder window never shows. S.D. does seem to work normally" except, I'm limited to the synthesized IR mode only, which I normally never use because the sampled rooms sound much better.

Toggling the button that switches between synthesized or real IR's does nothing, since I don't (can't) load a real IR file.

MacBook Pro 2.66 GHz Core I-7 4GB RAM 10.6.3 Logic 9.1.1 (64 bit mode)

Doug Zangar

Did you try going here?
Space Designer Presets.jpg

Lotus 7

Good suggestion. I had not tried using the default pop up.

I just tried it and there I do get a finder window. I can get to the IR folder and no files show at all. It appears to be empty. If I go to the same folder from the desktop, the IR files are all there and, of course, if I check from a S.D. window used in Logic, they are also there. Really strange. I've never seen a Mac with a finder window that didn't see files when opened from one location, but does when opened from another. This is a new laptop that is strictly used for on-location recording. There are no other applications on it other then what came with it from Apple. It's not used for anything else but recording and editing. It's not even connected to the internet. I'm stumped!


  • Screen shot 2011-07-06  .jpg
    Screen shot 2011-07-06 .jpg
    47.4 KB · Views: 111

Lotus 7

Thanks. That's probably the solution. Since all the IR files are actually in the folder, but just not being seen from WaveBurner, I may try some lower level fixes like trashing the WaveBurner Prefs. file first.

Usually, I apply major effects in Logic anyway and don't need to do it in WaveBurner. In this case the CD was already almost fully mastered with all track trims, track dynamics, and fades completed in WaveBurner and I just wanted to add a little touch more of S.D. reverb to one track. For now, I'm just going back to the original track in Logic to add the reverb and finish the CD.

Thanks again for your suggestions.


New Member
I joined the forum to specifically find out if others are experiencing this: I insert my 'space designer reverb' into my 'ultrabeat' track to give it some fx. I go to the presets 'ghost rhythms' (or any other preset for that matter) and select a 120bpm preset - when I click the preset a finder window opens looking for an .aif file. Needless to say, the preset doesn't load. I am on logic v. 9.1.4. Will try reinstalling as suggested.

Doug Zangar

@ Lotus7 - please post if you resolve this.

@sacrebleu - maybe repost in the Logic side of things. You'll get better response. But the short response here is can you get space designer to work in any channel strips?

Lotus 7

I tried reinstalling Logic Studio (which, of course, includes WaveBurner). The latest version I could find at Apple was V9.1.1 (1697.53 -64 bit). This made no difference. I still had a finder window (from the "Setttings" menu) which showed the IR folder, but no IR files inside. Also, no finder window at all from the load IR button on the S.D. plug in window.

I then installed the Apple "Pro Application 2010-02" which includes some "Logic Fixes". After installing the PA 2010-02 program, I now can see and load the IR files into Space Designer and they do work as expected in WaveBurner.

They only are visible from the "Settings" menu, still no finder window from the S.D. Load IR button.

However, I have discovered another problem using S. D. from within WaveBurner:

If I apply a S.D. effect to a single track (using the "region" tab) everything works as expected. BUT, if I apply the same S.D. effect to the whole mix (by adding the effect to the effects list under the "Mix" tab. The effect works fine (I can adjust the effect and switch it in or out) UNTIL I hit the bypass button. Then the effect is bypassed as expected, but hitting the Bypass button again does not bring the effect back. Nothing short of closing the project and reloading it will allow the effect to work again when I'm using it for the whole mix. (When hitting Bypass, each of the region "Effects enabled" boxes remains checked.)

When the effect is applied to only one region, the Bypass button works as expected and allows the effect to be turned off, and then turned back on.

In "Mix" mode, I can use the effect check box to toggle the effect as much as I need,but one touch of the Bypass button kills the effect until the project is closed and reloaded. It's not a real problem since the check box can be used to toggle the effect, but it is a problem if the Bypass button is accidentally hit.