Logic Pro 9 Video Of Logic / M-Audio Control Surface Transport Button Issue

turbojh

Logician
Dear Friends,

I am sorry to bother you with this, but I'm looking for a solution or suggestions to an issue I'm having when using the M-Audio ProjectMix Control Surface with Logic Pro...I've attached this short video to show you exactly what is happening:

http://www.youtube.com/watch?v=HOBWJiWv1Ao

My Logic song file loads up, the ProjectMix kicks in and everything seems to be fine. I hit the PLAY button on the ProjectMix, and the song begins to play. I then hit STOP, and the song stops and the locator jumps back to the beginning of the song (not sure how to change that)...

When I attempt to hit the PLAY button again, you can hear the song start for a brief second and then stop...the locator is locked to the beginning of the song, and using the jog wheel or FFWD or RWD will not work, with the locator either locking or jumping back to the beginning of the song.

If I hit the LOOP button the song will play again, but upon stopping the same problem arises, and hitting the LOOP button again doesn't resolve the issue.

I have looked at the control surface assignments and see no reason why this is happening...any thoughts or ideas? Any advice would be very much appreciated.

thanks guys,

Jeff
 

Peter Ostry

Administrator
Staff member
It is strange that your SPL jumps back to the start when you hit Stop. There are a couple of reasons for Logic to do this but not a single Stop command.

Does your ProjectMix run in Logic mode?
From the manual:
To enter Logic mode: Hold down the AUX 3 button while powering on the unit. The mode will be confirmed in the LCD display when the ProjectMix I/O has initialized.
---

Another idea:
From the Logic main menu go to File/Project Settings/MIDI -> Chase:

If your "Send full MIDI reset ..." is activated, switch it off and try if this changes the behavior.
 

turbojh

Logician
Thank you to all who responded: I am using Lion and have the latest driver for the Project Mix installed...the Project Mix is in Logic Mode, and the "Send full midi reset' is NOT activated...

Very perplexing...

Jeff
 

CSeye

Logician
Is this a new hook up? Or was the the Project Mix and Logic previously working together before some update or other change to your system?
 

turbojh

Logician
Hi, it's not a new hook-up, but it was left sitting for quite awhile as I had a busy fall...I don't recall this happening upon initial set up of this system last summer, but on the other hand I don't recall changing anything other than maybe loading a few midi drivers for some additional additional synths I have...
 

Peter Ostry

Administrator
Staff member
One idea ...
Disconnect all other MIDI devices. Maybe another device echoes your Stop command. Double stop would mean "jump to start".

Btw, you can see an echoed MIDI event in MIDI Monitor. This is free software and should be in everyones toolbox.

---

Another idea ...
Open the Controller Assignments (expert view) and press the Stop button on the PojectMix. The line with the "Stop" command should get selected. Disable the "Key Repeat" checkbox in the parameter panel. This is nonsense anyway for such commands. "Key Repeat" should be turned off for transport buttons, mute, solo etc.

---

No more ideas for now ...
 

CSeye

Logician
Top