Logic Pro 9 View Mode in Mix Window keeps changing

I started noticing this when I use a third party virtual instrument:

Let's say I have several tracks in the arrange window, with the correspondent channel strips in the mix window, and let's assume I'm seeing both windows as one (pressing "x" while I'm in the arrange window). And I always use the "Arrange" view mode in the mix window (as opposed to "Single" and "All").

Now if I start moving across tracks in the arrange windows, as soon as I get to a track that has a third party instrument (like omnisphere for example), the mix window automatically "updates" my view to "All".

Anyone know what's happening?

I'm using Logic 9.1
It might be because you are using the multiple output versions of these instruments and the aux tracks for the outputs aren't in your Arrange Window.
Upvote 0
Thanks Eli! By the way I'm a huge fan of your Groove3 tutorials, learned a lot from watching them.

I do have the aux tracks in the arrange window though. When I create a new multi output instrument, I check the "multi timbral" option, and then it automatically gives 16 tracks (which in turn I change to 8 for omnisphere). What happens then is that it creates these 8 tracks in the arrange window, and one channel strip in the mix window. Once I call up omni in this channel, I click the "+" button.

The weird thing is that, let's say I call the "original" channel strip "Omni 1" (before I clicked the "+" button). If I then call up the auxes by pressing +, the arrange window will reflect "Omni 1" in the last track, not the first one as I would assume. And the this problem of updating it to "ALL" instead of "Arrange" starts, which is driving me crazy, because it's very polluted.

By the way, it's amazing how this creation of multi output instruments is still very non intuitive in Logic.

Do you know what's happening Eli?

Thanks again for your response.

Upvote 0
I find the handling of multiple output / multi timbral instruments in Logic very kludgy the way it is currently. The behavior you are experiencing is perfectly repeatable and predictable. I can't explain it any other way than to say that's just the way it is in Logic right now. I have seen the exact same thing on several client's systems.

I've seen this phenomenon of the track name going to the highest numbered midi channel of the multi timbral instance. And then there's the issue of the aux's appearing at the end of the mixer when it goes into "All" view.

One thing that will help influence the behavior is to engage the track mixer view option for "all tracks with same channel strip/instrument. This will prevent the track mixer from jumping to all view.

The other thing that can have some influence over things is to change your configure track header dialogue box to display "channel strip name" instead of "auto name" - and then go in to the Environment Mixer and name the individual tracks manually there.

These two steps will give you some degree of control back over things.


  • Picture 1.png
    Picture 1.png
    18.7 KB · Views: 158
Upvote 0
Well, actually I thought it did, but it ended up bringing another issue:

By checking the "All tracks with the same channel strip" option in the mix window, now instead of having only the channel strip with the multi output instrument and its associated 7 auxes, I also have eight more tracks in the mix window, which apparently are just a mirror of the tracks that are in the arrange window.

You're right Eli, the handling in logic about multi output instruments is extremely kludgy.
Upvote 0