Logic Pro X Vocal Comp's creating overlapping doubled vocals, Why?

I'm comping a vocal, but instead of hearing each part of each take I want when I swipe, they're overlapping, so I'm getting doubled vocals for a second, even though I'm comping normally.

Is there some setting I've engaged I'm unaware of? This never happened before, I've comped many times.
 

sonnykeyes

Logician
In Preferences/Audio/Editing you can adjust the length of the crossfades during comping - perhaps yours has become adjusted to a longer crossfade..?
 
Top