Logic Pro 9 Vol Automation on Multi-Tibral Synths

#1
Hi all new here.
Had Logic 9 for a while.....with no drama's

But have only just noticed this when using as muti-timbal.....
When I do vol automation on say track 1 ie: Kore 2 or Virus TI as multi-timbal in the arranger,
all midi tracks 1 - 16 change there vol at the same time.

Q....Is there a setting in preferences I'm missing ?
Or
Is this normal ?

Most of the stuff I've already done has been with instrument , guitars , bass ie: Mono , Stereo , Instrument tracks.............So haven't noticed this until now.

Just slightly confused as I can't find the answer to this in the manual.

I'm on iMac 10.5.8 2.4Ghz 4Gb USB edirol interface UA-25EX
With all the latest updates.....

Hope someone can help me here as I've also got Komplete 5 + 6 ,
Maschine , Virus TI , Kore 2 , & other Muti-timbal units....
That I'd like to use this way as multi-timbal.

I've come from Cubase 4 & thought you could do this in there but can't remember.

Have done a search here to no avail !!!

Cheers To Ya & Thanks
 
#2
Logic reserves Volume CC7 and panning for the instrument as a whole, so you need to use CC11 or CC1 for volume if you want to automate MIDI channels discretely. Alternatively if the instrument is multi-output as well, you can create auxes for the outputs and automate them with CC7.

Logic is simply not the most multi-timbral friendly app and I know that at least some at Apple consider it a dated workflow.
 
#3
Hi Jay Asher

Yep I knew about routing to other auxes using the multi outputs.
But thats not really my problem.....

As you stated vol automation on separate midi tracks using muti-tibral can be done.
By using CC11 or CC1

Could you please explain how I go about this ?

Because you haven't stated how this is done.......

As I've tried changing Vol CC # in Hypo editor when I change to CC11 for Vol it changes to expression & CC1 changes to Modulation also if done in 1 midi track it's the same for all others midi tracks.

Or is this done somewhere else & not in hypo editor !!!
Do I nave to do something in settings or preferences !!!

So if you or somebody could show me the best possible way to set this up I'd be very grateful, as you said it can be done.........But I'm Stumped on this one.........

Cheers To Ya & Thanks So Much For Your Help
 
#4
Hi zmmooz, I may not be an expert but I thought you could use the EXS Modulation Matrix to redirect MIDI channels. If that Is not possible a Transformer can change the MIDI channels, again I am no expert,they will surely be getting to your question as fast as is possible. I am not certain where the transformer needs to be set up-it could be in the Environment in the signal flow,check in the manual about the use of the transformer.
 
#6
Thanks CSeye

That would be tops & help heaps,
As I couldn't understand reply from David51
I know what the transformer is
But not sure how to use as yet.....I am reading manual...
But don't know what Exs Mod Matrix is !!! Can't find that in Logic 9

Main reason I need this setup is for Virus TI Synth....As you can
ONLY have 1 instance of this , either as Multi-timbal or as an Instrument
All other products I have can have as many instance's as computer can handle.

Thanks so much in advance....What a cool name you've got

Cheers To Ya....Zummooz
 
#8
Thank You So Much......CSeye

I've never really gone into the "Environment"
Mainly because in the manual it says you don't really need to use this.
But for this issue I'm having, I shall be looking more seriously into this area.
Thank you so much for helping me out on this subject.

Nice piece of work on the supplied download.....Thanks
Shall delve into this later tonight.......

As I stated before I've had no other problems with Logic 9
I do believe this is a good DAW.....Well I'm happy :D

Also thanks to all others that have had an input here.

Cheers To Ya All & Thanks Again CSeye.....Enjoy The Weekend :thmbup:

P.S.......Off to learn some Logic tricks........;)
 
#9
Hi all.....

OK...I've spent 8 hours trying this to no avail !!!!!! :brkwl:

Have done as stated in download file......
Have read Environment manual 3 times.....

To start with in the Environment
I don't see CC#7 in input view while moving Vol.
Have changed Transformer as shown in download file, from....
CC#7 to CC#11 & tried CC#1.......But nothing
In the mixer view I still see CC#7 showing in the monitor while moving vol.
Also in Environment I have #1 - #7 in multi instrument, as I have 7 midi tracks. ( Hope this bit is right )

All midi channels still moving vol automation as one........

So I'm back to square one on this problem.....HEEEEEEEELLLLP..........PLEASE.......

Cheers To Ya
 
#10
Learning the Environment takes time and patience. Having said that, my suggestion would be to frequently ask questions along the way rather than going crazy for 8 hours. Complex tasks can be broken down into smaller steps.

Going back to the beginning:

Step 1. in the pdf shows the Clicks and Ports. That name should be visible in the pop up window in the upper left of the Environment.

The big object to the left is the Physical Input object which shows all input devices available to Logic: hardware (keyboards, controller surfaces) and software such the Cap Lock MIDI keyboard.

When I move a hardware controller fader assigned to CC#7, it shows up as depicted in step one in the pdf file.

What are you using to input CC#7?
 
#11
Hi all.....

OK...I've spent 8 hours trying this to no avail !!!!!! :brkwl:

Have done as stated in download file......
Have read Environment manual 3 times.....

To start with in the Environment
I don't see CC#7 in input view while moving Vol.
Have changed Transformer as shown in download file, from....
CC#7 to CC#11 & tried CC#1.......But nothing
In the mixer view I still see CC#7 showing in the monitor while moving vol.
Also in Environment I have #1 - #7 in multi instrument, as I have 7 midi tracks. ( Hope this bit is right )

All midi channels still moving vol automation as one........

So I'm back to square one on this problem.....HEEEEEEEELLLLP..........PLEASE.......

Cheers To Ya
Email me and I will send you a template with a transformer that will globally change CC7 to CC11 data for you.

jay@jayasher.com
 
#12
Hi all

Thanks guys.....for all your help....:thmbup:
Don't worry I wasn't realy bashing head against a wall !!

I've SOLVED my main problem Thou , of not being able to use Muti-timbral
Vol automation with Virus TI Synth...

By going to each Midi track in arranger, Opening small triangle bottom left corner,
to open Vol automation panel , then pressing Volume, which opens pannel with....
Main & 1 Virus TI & Display Off & Volume & Pan.

Went to 1 Virus TI which gave me Parts 1 - 16
Go to Part 1 for Midi track 1
Then had full choice of different parameters.....
Selected CC#7 for Volume Automation
Bingo was able to Automate Vol from each midi track.
And what ever else I'll need
With out using the Environment

Dummy.........I Know..........:redface:

But have always used Virus TI as analog...NOT as Muti-Timbral midi

Now trying the same as above with Kore 2 with no success as yet.

I really hope I haven't sent you astray or NUTS with my Q.......

Thanks Jay Asher received Template Thank you again.
I'm sure with all the bits & pieces, I'll get there.

Thanks to All........on this Topic
Cheers To Ya ;)
 
Top