• Welcome to Logic Users Group V2.0.4

    We have a few new features and changes See here

Logic Pro X volume automation problem

#1
I have a session of audio tracks, volume is jumping up to max at random
points in the track, happening on several tracks, putting a new node in
brings it back to where it should be, but happens randomly further along the
track. Tried deleting all automation from the track, problem re-occurs.
Any ideas?
Doesn't happen with automation turned off, keeps steady volume.
Doesn't seem to affect any other automation - have reverb and eq automation,
all seems to work fine, except volume.
 

Eli

Logician
#2
How are you deleting your automation? It seems you still have some happening that you are not seeing.

If you haven't already, try using this menu command to make sure all automation is deleted:
 

Attachments

#3
try using this menu command to make sure all automation is deleted:
This will delete the all automation on that track - where the reverb and EQ are OK regarding the OP. There are a few methods to delete a given automation definition. For example:
1. Open the Automation Event List (There is a key command for that).
2. Select any Control Change # 7 (this is the volume), use the "Edit" command "Select Similar" or the correspondent key command to select all CC7 and delete.
Another alternative is to do that in Automation View (Main Window) mode and show/select/delete the Volume TBA nodes only.

BTW.Dwdavedw,
There is one more "Batch" alternative if you have to process lots of tracks. If you have any interest I can outline it...
 
#4
OK, I can't get to the automation event list - the key command opens evernote, won't work within logic, even if evernote is quit. urg. is there another way
to open hidden windows like that without having to make a new key command?
Anyway, I had already tried by deleting all automation for the track, that didn't work, then did the delete all automation as you suggested, played the track for
about a 1:50, thought it was all set, then it popped up again, volume went up
to max level at random point - played it from the beginning again, and happened
about 10 sec into the track, so it's random. I looked in the inspector - even though the track header is set to automation, the inspector was showing flex
mode as on, I turned flex mode off in the inspector, so far 2 times thru the track
it has not re-occurred.
Hmmm.
 

Eli

Logician
#5
Is there any MIDI CC automation in any of the regions? Any MIDI Draw (used to be called hyperdraw)? Have you tried looking in an event list to see if there is CC data there that is unintended?
 

Whiffle

New Member
#6
I know this is quite a few years since, but I just ran into this problem in Logic Pro X 10.4.1 on an audio track. I tried all the above suggestions, including some other places where the "Delete All Automation" command existed. No luck. As I only had it on happening on a single track, I was able to create a new track with the same basic settings (command d) and simply drag the audio to this new track. I hadn't started putting automation on the track, but my settings are such that create new track seems to recycle tracks automation from the great beyond sometimes. I deleted all the automation before I began to record, but possibly some artifact may have remained.
 
#7
...I only had it on happening on a single track...
Was it by any chance the track you had selected? I've had this happen with a MIDI keyboard that occasionally sent CC7 (Volume) data in response to vibrations in the floor, and it seemed like I was getting ghost automation from nowhere. The only solution (other than buying a new keyboard) was to make a new track with nothing on it and keep that selected when I was playing back so the randomly generated CC7 data wouldn't change my mix.
 

Whiffle

New Member
#8
That could be likely, now that you mention it. I haven't been able to recreate it, and there isn't any midi information on the track now. Oddly just yesterday I did a scratch vocal track and noticed there was pitch bend information on it. In that way one can get in the flow, I simply opened the list editor, deleted it and moved on. I normally mute the track on my interface when I'm done working with the mic, but I noticed I'd forgotten to after recording the scratch track. Maybe I caught this hitch in my process the last couple days. Didn't even know this was possible, but then I just accidentally found transpose on the audio track only last week. I've been using logic since it was Notator on an Atari, and I'm still amazed at how much there is to learn.

To try my version of your solution, I can usually turn that controller off when I play and sing ( It's a M Audio Axiom Pro), as the keyboard I play on is a 88 key with a fairly stiff dial volume and no pitch wheel. Thanks for the idea.
 

Peter Ostry

Administrator
Staff member
#9
the keyboard I play on is a 88 key with a fairly stiff dial volume and no pitch wheel
We cannot trust the stiffness of dials, wheels and other manual feelings. For example, I have a Studiologic 990 Pro here, everything feels ok, but it sends PitchBend occasionally on it's own.

To get sure, you may install the freeware MIDI Monitor, activate only ports of the keyboard and other (currently unused) MIDI controllers and leave the App's window open the whole day. You would see everything that comes in without your knowledge. Snoize MIDI Monitor is a valuable tool anyway.
 
#10
I just checked, there is no dial on a Kawai VP-1 (other than the on/off button, it's under a rubber mat). So if I turn off the Axiom Pro, problem solved. I don't ever use pitch bend or the mod wheel while I'm singing anyway (I only play piano parts then). The Axiom other than the keys and mod wheel are very stiff anyway. Other controllers have looser components which I actually like. If I run into it with one of those in the future, I'll come back and find this.
 
Top