Logic Pro 7 & earlier VST 2.4 Support for Logic Platinum 5.5

#1
Hi,
I have been trying to install audiorealism bassline 2 into Logic Platinum 5.5, but no sound comes out at all. I have found out that Logic Platinum 5.5 only supports up to VST2.3 and ABL2 is VST 2.4. Is there anything I can do? Is there any VST 2.4 upgrades available? I dont like cubase and I cant afford to get a Mac just to over come this.

Thanks

Energise
 

Markdvc

Administrator
Staff member
#2
I very much doubt that anything can be done - there certainly won't be any changes to Logic 5.x, the only solution would be if the plugin developer would recode, but epecting that to accomodate a program that was discontinued over 6 years ago would be wildly optimistic.

kind regards

Mark
 
#3
Thanks for your reply. I managed after much searching to find a 2.3 version of the program i was looking for. It works perfectly. I can still see this being a problem in the future though. Im going to have to change to mac at some point cause logic is my sequencer of choice and logic 8 looks amazing. Logic 5 is fully capable but i can see more and more problems will arise in the future.
 
#5
I would just buy logic 8 or 9. 5 is an old version on PC, Im pretty sure Apple wouldnt have an upgrade. If they did it wouldnt be much of a saving.
 

Markdvc

Administrator
Staff member
#6
Actually, the upgrade from Logic 5 to 8 was 199 USD/euro. I am unsure as to whether the current 199 Upgrade to Logic 9 is valid for Logic 5 but this would be worth your while checking, it is less than half the price for the full version of Logic 9.

kind regards

Mark
 
Top