Logic Pro X When I change the clef to a percussion clef the notes disappear

dksellou

Logician
Hello,
I am new to Logic.
I have a track for Claves and a track maracas (the first uses a middle C for the sound and the latter a C above).
In the notation score they had by default a treble clef. When I tried to use the "drums" clef which is actually a percussion clef) the notes disappear from the staff.
Any idea how to fix this?
Or is it possible t create your own staves?
Thanks
 
Last edited:

CSeye

Logician

Attachments

  • Mapped instruments & staff styles.png
    Mapped instruments & staff styles.png
    141 KB · Views: 11
  • Mapped instrument.png
    Mapped instrument.png
    101.1 KB · Views: 12
Upvote 0

dksellou

Logician
Upvote 0

dksellou

Logician
Upvote 0

dksellou

Logician
so irritating that it so hard to find how to create the mapped instrument. What is the Logic Environment window? I cannot find it...
 
Upvote 0

CSeye

Logician
⌘0 (command plus 0) opens the Environment. (The environment is deemed a legacy feature by Apple even though the Environment is Logic!)
In my case it always opens with the Mixer layer in the upper left pop-up.
From the New menu, select mapped instrument.
Cable it to whatever channel strip you are using as sound source for percussion sounds.
 

Attachments

  • Environment.png
    Environment.png
    216.9 KB · Views: 7
Upvote 0

dksellou

Logician
⌘0 (command plus 0) opens the Environment. (The environment is deemed a legacy feature by Apple even though the Environment is Logic!)
In my case it always opens with the Mixer layer in the upper left pop-up.
From the New menu, select mapped instrument.
Cable it to whatever channel strip you are using as sound source for percussion sounds.
you are a life savior. I almost got crazy for not being able to find it!
Thanks again!
 
Upvote 0

dksellou

Logician
ok I feel dumb
All I am trying to do is to use a single percussion staff for the Claves instrument. The notes of the claves are only mapped to Middle C.
I created a single line percussion clef and when I change the claves staff to that percussion clef the notes disappear.
I tried to create the mapped instrument but it is so confusing....I guess I will have to leave it as it is (treble clef) showing a middle c...this is so annoying...
 
Upvote 0

CSeye

Logician
There is an alternative that does not require a mapped instrument, but does require the following for a single line notation per percussive instrument:
- Load a separate Sampler instrument per track: Library>Factory>Drums & Percussion>Percussion>Single instruments>....
- All notes per midi region per track will need to be transposed to F#1
- Duplicate the #Drums staff style. Change the staff style clef to Drums 1

This is as simple as it gets.
 
Upvote 0

dksellou

Logician
I am using a third party sample for claves (cineperc) and not the logic sounds but I am sure the same principle applies, right?
Thank you so much!
 
Upvote 0

CSeye

Logician
The devil's work is at play here with some illogical maneuvers.
I'm assuming your instrument has different percussion instruments on the key map: C3=claves, C4=?
- Create a new mapped instrument and cable it to your instrument.
- Since your instrument has claves on C3, the mapped instrument C3/Bongos will work just fine.
- For C4, in the mapped instrument, create a new group and name it for your specific voice. In my case, I created a claves group on D#4 as that assignment worked with my instrument of choice.

Open the staff styles window
- create a new mapped style
- change the kick group to bongos
- add another group, and select the group you created for C4, D#4/claves in my case.

In the track inspector, I needed to select the mapped style for both tracks before that option would appear in the region inspector.
Once this is eventually acclomplished, your region with C3 should appear as a single line staff in the score.

To only way I could get the second track to display the staff style correctly for D#4 was to drag the mapped instrument object in the environment to the track header.

This sequence of steps was repeatable on this end. It is fiddly but efficiency is achieved with familiarity.

That's all I have.
Good luck.
 

Attachments

  • Claves map.png
    Claves map.png
    62.7 KB · Views: 9
  • mapped staff style.png
    mapped staff style.png
    162.1 KB · Views: 9
  • drag to track header.png
    drag to track header.png
    143.1 KB · Views: 9
Last edited:
Upvote 0

dksellou

Logician
The devil's work is at play here with some illogical maneuvers.
I'm assuming your instrument has different percussion instruments on the key map: C3=claves, C4=?
- Create a new mapped instrument and cable it to your instrument.
- Since your instrument has claves on C3, the mapped instrument C3/Bongos will work just fine.
- For C4, in the mapped instrument, create a new group and name it for your specific voice. In my case, I created a claves group on D#4 as that assignment worked with my instrument of choice.

Open the staff styles window
- create a new mapped style
- change the kick group to bongos
- add another group, and select the group you created for C4, D#4/claves in my case.

In the track inspector, I needed to select the mapped style for both tracks before that option would appear in the region inspector.
Once this is eventually acclomplished, your region with C3 should appear as a single line staff in the score.

To only way I could get the second track to display the staff style correctly for D#4 was to drag the mapped instrument object in the environment to the track header.

This sequence of steps was repeatable on this end. It is fiddly but efficiency is achieved with familiarity.

That's all I have.
Good luck.
What a nice person you must be to have spent so much time trying to help a stranger.
I am really speechless for your kindness.

I will definitely do it Monday.
Thank you so much and God bless you!
 
Upvote 0
Top