will Logic Pro 7 work with OS X 10.6?

jonny quest

New Member
I was thinking of updating my OS X from 10.4 to 10.6 but I want to make sure my Logic Pro 7 will still work. I'd be devastated to load a new operating system and find that my software no longer works.
 
I really wouldn't suggest it. To go up 2 OS's is one HUGE thing, but to expect Logic to work perfect.... Stay where you are, it's faster than it will be if you upgrade, and it is more reliable that it will be if you upgrade.

I'd say don't bother, you are going to be very unhappy in the end.

Can I ask why you are wanting to try this?
 
No, I'm on a current gen i7 chip Mac Pro (kinda)...

If you are on a PPC you can't upgrade past 10.5.8 anyways, and if you are going from a PPC to a Mac Pro, it's a long haul. Don't use the migration assistant between CPU types (PPC to Intel specifically) it will make a very unreliable system. So you will need to be sure to upgrade all your apps to universal versions...

Then there is the issue of taking Logic Pro 7 sessions and opening them in Logic Pro 9. Someone can tell you (and me for that matter) which items need to be removed from your L7 song environment to make them work properly in Logic Pro 9... Suffice to say, it's a bit of a journey, do not expect to just start the new system, copy all your old apps and user folder into it, and you are ready to go...
 

jonny quest

New Member
I really wouldn't suggest it. To go up 2 OS's is one HUGE thing, but to expect Logic to work perfect.... Stay where you are, it's faster than it will be if you upgrade, and it is more reliable that it will be if you upgrade.

I'd say don't bother, you are going to be very unhappy in the end.

Can I ask why you are wanting to try this?

I want to try this to run some newer sofware/instruments. For example, Komplete 7 will only work on 10.5 +
 
Top